incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <>
Subject Re: [Android] Plugin.ctx needs a rename
Date Mon, 18 Jun 2012 20:35:49 GMT
Brian, we're doing Android devs (potential plugin authors) a favor here,
trust me.

2.0 is our chance to break interfaces.

Also, +1 to Bryce's comment re: get this change in for 1.9, deprecate the
.ctx member in 1.9 as well, and axe it in 2.0.

On 6/18/12 12:15 PM, "Brian LeRoux" <> wrote:

>I'm of the opinion that native impl should *not* abstract the
>platforms at the plugin level. It breaks old plugins, which is fine,
>but for what benefit? Conceptual purity at that level will make it
>harder to recruit plugin authors from their respective navtive
>On Mon, Jun 18, 2012 at 3:06 PM, Michael Brooks
><> wrote:
>> If we are planning to rename the Cordova interface object, then we
>> do it for each platform in a consistent manner. There should be a parent
>> JIRA issue with sub-tasks for each Cordova platform.
>> On Mon, Jun 18, 2012 at 11:50 AM, Filip Maj <> wrote:
>>> Yeh "ctx" implies Context, especially for Android peoples, so +1 to
>>> renaming to something less Android-ey.
>>> On 6/18/12 11:45 AM, "Joe Bowser" <> wrote:
>>> >Hey
>>> >
>>> >Since we're approaching 2.0 and since part of the goals of 2.0 is to
>>> >improve the plugin architecture, I'm wondering if we should take the
>>> >opportunity to give the CordovaInterface variable on a
>>> >other than ctx, which on Android usually refers to a context.  The
>>> >for this is the fact that there's a use case where the
>>> >may
>>> >not be a Context.  I propose that we change the name to cordova.
>>> >
>>> >I'm not sure if this needs a JIRA ticket or not.
>>> >
>>> >Any thoughts?
>>> >
>>> >Joe

View raw message