incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <>
Subject Re: [Android] Plugin.ctx needs a rename
Date Mon, 18 Jun 2012 18:50:27 GMT
Yeh "ctx" implies Context, especially for Android peoples, so +1 to
renaming to something less Android-ey.

On 6/18/12 11:45 AM, "Joe Bowser" <> wrote:

>Since we're approaching 2.0 and since part of the goals of 2.0 is to
>improve the plugin architecture, I'm wondering if we should take the
>opportunity to give the CordovaInterface variable on a name
>other than ctx, which on Android usually refers to a context.  The reason
>for this is the fact that there's a use case where the CordovaInterface
>not be a Context.  I propose that we change the name to cordova.
>I'm not sure if this needs a JIRA ticket or not.
>Any thoughts?

View raw message