incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Brooks <mich...@michaelbrooks.ca>
Subject Re: [Android] Plugin.ctx needs a rename
Date Mon, 18 Jun 2012 19:06:17 GMT
If we are planning to rename the Cordova interface object, then we should
do it for each platform in a consistent manner. There should be a parent
JIRA issue with sub-tasks for each Cordova platform.

On Mon, Jun 18, 2012 at 11:50 AM, Filip Maj <fil@adobe.com> wrote:

> Yeh "ctx" implies Context, especially for Android peoples, so +1 to
> renaming to something less Android-ey.
>
> On 6/18/12 11:45 AM, "Joe Bowser" <bowserj@gmail.com> wrote:
>
> >Hey
> >
> >Since we're approaching 2.0 and since part of the goals of 2.0 is to
> >improve the plugin architecture, I'm wondering if we should take the
> >opportunity to give the CordovaInterface variable on Plugin.java a name
> >other than ctx, which on Android usually refers to a context.  The reason
> >for this is the fact that there's a use case where the CordovaInterface
> >may
> >not be a Context.  I propose that we change the name to cordova.
> >
> >I'm not sure if this needs a JIRA ticket or not.
> >
> >Any thoughts?
> >
> >Joe
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message