incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bowser <>
Subject [Android] Plugin.ctx needs a rename
Date Mon, 18 Jun 2012 18:45:46 GMT

Since we're approaching 2.0 and since part of the goals of 2.0 is to
improve the plugin architecture, I'm wondering if we should take the
opportunity to give the CordovaInterface variable on a name
other than ctx, which on Android usually refers to a context.  The reason
for this is the fact that there's a use case where the CordovaInterface may
not be a Context.  I propose that we change the name to cordova.

I'm not sure if this needs a JIRA ticket or not.

Any thoughts?


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message