incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bryce Curtis <>
Subject Re: [Android] Plugin.ctx needs a rename
Date Mon, 18 Jun 2012 19:08:05 GMT
Makes sense - I'm fine with rename for 2.0.  We may want to introduce
"cordova" into 1.9 and keep "ctx" with deprecation notice.  Also, make
sure it's documented.  This will break plug-ins when removed.

On Mon, Jun 18, 2012 at 1:50 PM, Filip Maj <> wrote:
> Yeh "ctx" implies Context, especially for Android peoples, so +1 to
> renaming to something less Android-ey.
> On 6/18/12 11:45 AM, "Joe Bowser" <> wrote:
>>Since we're approaching 2.0 and since part of the goals of 2.0 is to
>>improve the plugin architecture, I'm wondering if we should take the
>>opportunity to give the CordovaInterface variable on a name
>>other than ctx, which on Android usually refers to a context.  The reason
>>for this is the fact that there's a use case where the CordovaInterface
>>not be a Context.  I propose that we change the name to cordova.
>>I'm not sure if this needs a JIRA ticket or not.
>>Any thoughts?

View raw message