incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shazron Abdullah (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (CB-956) Obscure errors with iOS simulator and XCode 3
Date Mon, 25 Jun 2012 17:39:42 GMT

    [ https://issues.apache.org/jira/browse/CB-956?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13400704#comment-13400704
] 

Shazron Abdullah edited comment on CB-956 at 6/25/12 5:37 PM:
--------------------------------------------------------------

Xcode 4 is required because Apple requires the latest shipping SDK for App Store submissions,
and the latest shipping SDK (iOS 5) requires Xcode 4. 

I'll update the relevant docs.
                
      was (Author: shazron):
    Xcode is required because Apple requires the latest shipping SDK for App Store submissions,
and the latest shipping SDK (iOS 5) requires Xcode 4. 

I'll update the relevant docs.
                  
> Obscure errors with iOS simulator and XCode 3
> ---------------------------------------------
>
>                 Key: CB-956
>                 URL: https://issues.apache.org/jira/browse/CB-956
>             Project: Apache Cordova
>          Issue Type: Bug
>          Components: Docs, iOS
>    Affects Versions: 1.8.0, 1.8.1
>         Environment: OS X 1.6.8 Snow Leopard, XCoode 3.2.6
>            Reporter: Lauri Peltonen
>            Assignee: Shazron Abdullah
>              Labels: documentation, xcode
>
> I was trying to upgrade from 1.7.0 to 1.8.x.
> When the simulator is already running and I relaunch the application, the console gets
about 30 of such error messages:
> 2012-06-25 14:50:03.876 RSBooks-Mac[2268:1803] *** __NSAutoreleaseNoPool(): Object 0x5a7b740
of class NSFileAttributes autoreleased with no pool in place - just leaking
> 2012-06-25 14:50:03.880 RSBooks-Mac[2268:1803] *** __NSAutoreleaseNoPool(): Object 0x5d36400
of class __NSDate autoreleased with no pool in place - just leaking
> I visited PhoneGap IRC channel and they suggested that it might be so that XCode 3.x
is not supported anymore. The latest installation guide says that OSX 1.7 is a requirement,
but the upgrade guide doesn't mention anything about that.
> If it really is so that XCode 3.x is not supported anymore, then I hope the upgrade guide
can be edited (nobody goes to the installation page for upgrades) or if it's a normal bug,
then it could be fixed.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message