incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Trice (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-675) Allow multiple versions of PhoneGap to be installed in Xcode
Date Wed, 09 May 2012 20:43:59 GMT

    [ https://issues.apache.org/jira/browse/CB-675?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13271785#comment-13271785
] 

Andrew Trice commented on CB-675:
---------------------------------

Patrick, that is exactly what I'm suggesting: "you can never create a new project with an
OLD version, but projects created from an OLD template will continue to work."

Shaz: I don't mean just the JS file, but the actual Cordova.lib in Xcode gets overwritten.
So, project A still has the JS for 1.4, but the 1.7 library has been installed on the computer
(which overwrote the 1.4 Xcode library).  In this case the 1.4 JS isn't matching up with the
1,7 native library.   If you automatically switch out the JS (as mentioned in CB-385) it has
potential to cause more bugs in developer's code, and they won't know why.   What I am suggesting
is that if you create a project with PhoneGap 1.5, include a copy of the 1.5 library in the
Xcode project, so future installations don't break existing projects.   
                
> Allow multiple versions of PhoneGap to be installed in Xcode
> ------------------------------------------------------------
>
>                 Key: CB-675
>                 URL: https://issues.apache.org/jira/browse/CB-675
>             Project: Apache Cordova
>          Issue Type: Bug
>            Reporter: Andrew Trice
>
> There is one thing that is driving me crazy with PhoneGap.  Currently in OSX, the Xcode
project always references the machine's PhoneGap library.  For a single project, this is fine.
 If you have multiple projects on your machine, and they use different versions of the PhoneGap
SDK, then there is no way to easily manage the correct version of the SDK.  Whether your project
is PhoneGap 1.5 or 1.7, it will reference the last installed SDK.   If you try and run a PhoneGap
1.5 app on a machine where you last installed the 1.7 RC, then the 1.5 app is likely to have
errors (compiler errors from changes in the SDK, as well as JS errors).   It would be great
to have either versioned SDK libraries so that you can have multiple PhoneGap versions installed
at the same time, or have a reference to the PhoneGap library in each project, so that installing
a new SDK doesn't break older projects.   

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message