incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Maj (JIRA)" <>
Subject [jira] [Commented] (CB-560) Cordova breaking iOS plugins
Date Tue, 01 May 2012 19:46:55 GMT


Filip Maj commented on CB-560:

Do not think CB-298 has anything to do with this. We are missing adding the cordova/exec JS
module on the {{Cordova}} and {{PhoneGap}} globals; for the {{cordova}} global, this is done
[via the common.js platform definition|],
but that is missing for {{Cordova}} and {{PhoneGap}}.
> Cordova breaking iOS plugins
> ----------------------------
>                 Key: CB-560
>                 URL:
>             Project: Apache Callback
>          Issue Type: Bug
>          Components: CordovaJS
>    Affects Versions: 1.6.1
>         Environment: From!topic/phonegap/2G5OPKV_FdQ
someone apparently tried upgrading from PhoneGap 1.1 to 1.6.
>            Reporter: Chris Brody
>            Assignee: Filip Maj
>             Fix For: 1.7.0
>   Original Estimate: 4h
>  Remaining Estimate: 4h
> From 1.4 to 1.5, the namespace was changed from PhoneGap to Cordova which was breaking
all of the existing plugins. I eventually provided a shim class but it was too late to stop
the pain. Then in Javascript only Cordova was changed to cordova, breaking the iOS plugins
yet again. I noticed in cordova (1.6.0) JS:
> if (!window.PhoneGap) {
>     window.PhoneGap = cordova;
> }
> This should have been done for Cordova like:
> if (!Cordova) {
>  Cordova = cordova;
> }
> Yes we should be deprecating the old namespaces for removal in another major release.
Any API changes made before a major release should be made with a workaround, to be deprecated,
and tested with some plugins before shipping.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message