incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michał Letyński (Issue Comment Edited) (JIRA) <j...@apache.org>
Subject [jira] [Issue Comment Edited] (CB-499) Cordova 1.6 breaks with RequireJS
Date Sun, 15 Apr 2012 08:27:28 GMT

    [ https://issues.apache.org/jira/browse/CB-499?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13254280#comment-13254280
] 

Michał Letyński edited comment on CB-499 at 4/15/12 8:27 AM:
-------------------------------------------------------------

I have the same problem for IOS, i have cordova defined as module. I get such error:

2012-04-15 12:20:57.382 [8730:13403] Error: executing module function 'setInfo' in module
'cordova/plugin/ios/device'. Have you included the iOS version of the cordova-1.6.0.js file?

When i move cordova from requiredJs and define it in index.html this error disappear. However
i have problem with my custom plugins ... Im adding them via:

cordova.addConstructor(function() {
 //code
});

However this constructor is never invoked. When i remove required.js reference everythink
works ...  
Also everythink worked in 1.5 version. 
I didn't notice any information/warnings in update guide according to required.js and new
cordova 1.6.
                
      was (Author: mikel):
    I have the same problem for IOS, i have cordova defined as module. I get such error:

2012-04-15 12:20:57.382 fwuiPadClient[8730:13403] Error: executing module function 'setInfo'
in module 'cordova/plugin/ios/device'. Have you included the iOS version of the cordova-1.6.0.js
file?

When i move cordova from requiredJs and define it in index.html this error disappear. However
i have problem with my custom plugins ... Im adding them via:

cordova.addConstructor(function() {
 //code
});

However this constructor is never invoked. When i remove required.js reference everythink
works ...  
Also everythink worked in 1.5 version. 
I didn't notice any information/warnings in update guide according to required.js and new
cordova 1.6.
                  
> Cordova 1.6 breaks with RequireJS
> ---------------------------------
>
>                 Key: CB-499
>                 URL: https://issues.apache.org/jira/browse/CB-499
>             Project: Apache Callback
>          Issue Type: Bug
>          Components: CordovaJS
>    Affects Versions: 1.6.0
>         Environment: Android, Cordova 1.6.0, RequireJS 1.0.7
>            Reporter: Dewang Shah
>            Assignee: Filip Maj
>
> Cordova 1.6 breaks compatibility with RequireJS. This uesd to work in 1.5 but now stops
all other Require modules from loading. The deviceready event fires within seconds (much sooner
that 1.5) and then all modules fail to load.
> Making Cordova the last module to load does not make any difference.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message