incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Maj (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (CB-499) Cordova 1.6 breaks with RequireJS
Date Wed, 18 Apr 2012 08:05:13 GMT

     [ https://issues.apache.org/jira/browse/CB-499?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Filip Maj updated CB-499:
-------------------------

    Attachment: www-michal.tar.gz

The attached example (thank you Michal for the code) can reproduce the issue. I was using
1.6.1 (although 1.6.0's cordova.js is inside the attachment).
                
> Cordova 1.6 breaks with RequireJS
> ---------------------------------
>
>                 Key: CB-499
>                 URL: https://issues.apache.org/jira/browse/CB-499
>             Project: Apache Callback
>          Issue Type: Bug
>          Components: CordovaJS, iOS
>    Affects Versions: 1.6.0, 1.6.1
>         Environment: Android, Cordova 1.6.0, RequireJS 1.0.7
>            Reporter: Dewang Shah
>            Assignee: Filip Maj
>             Fix For: 1.7.0
>
>         Attachments: www-michal.tar.gz
>
>
> Cordova 1.6 breaks compatibility with RequireJS. This uesd to work in 1.5 but now stops
all other Require modules from loading. The deviceready event fires within seconds (much sooner
that 1.5) and then all modules fail to load.
> Making Cordova the last module to load does not make any difference.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message