incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Johnny Ray <joh...@johnnyray.me>
Subject Re: Confusion
Date Wed, 14 Mar 2012 23:43:04 GMT
I was seeing this message in the cordova-js repo 

https://github.com/apache/incubator-cordova-js

Scroll down to 'Supported Platforms' in the read me.

Thanks for the plugin documentation. Suppose I wanted to simply extend the current core API,
is there documentation on how to do that on the JavaScript side - the native stuff is easy
enough. I suppose we're a bit confused on exactly how to accomplish that. There are so many
repos out there is difficult to know what is up to date, what is being used by the community,
what to fork if you want to contribute. We've gone through the wiki but some further guidance
would be appreciated. 

-- 
Johnny Ray
http://johnnyray.me/


On Wednesday, March 14, 2012 at 11:22 AM, Shazron wrote:

> On Wed, Mar 14, 2012 at 8:04 AM, Johnny Ray <johnny@johnnyray.me (mailto:johnny@johnnyray.me)>
wrote:
> > A colleague and myself were trying to add functionality to the iOS framework. When
we were attempting to actually create the JS side code we were a bit confused about things
not seeming to work. Two things:
> > 
> > 1.) We notices a section in the JS read me which says the only supported platform
is Android. Can someone explain what is meant by this?
> 
> Not sure - where exactly are you seeing this?
> 
> > 2.) If it iOS JS changes are supported at this point where can we find more documentation
as to how to get things wired to the native side?
> 
> By the time 2.0 rolls around, plugin interfaces will probably change
> for the better. I would go to
> http://github.com/phonegap/phonegap-plugins/iOS and look at some code
> there. There is a general guide available at
> http://wiki.phonegap.com/w/page/36752779/PhoneGap%20Plugins
> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message