incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joe Bowser <bows...@gmail.com>
Subject Re: Cordova-Android jar generation problem
Date Fri, 02 Mar 2012 02:02:51 GMT
Cool. Glad to hear it worked!

On Thu, Mar 1, 2012 at 5:57 PM, Marlin Mixon <marlin.mixon@gmail.com> wrote:

> Thanks.  I found out that the problem was I was running ant version
> 1.7.1 which was incompatible with the build file.  I upgraded to the
> latest 1.8.3 and it worked without a hitch.  FFR 1.8.0 is the minimum
> ant version.
>
> On Thu, Mar 1, 2012 at 7:13 PM, Filip Maj <fil@adobe.com> wrote:
> > When you generate the jar successfully after running ant jar, it should
> > exist directly under the /framework directory (cordova.1.5.0rc1.jar).
> >
> > Next step is to take this jar and replace the cordova.jar that already
> > exists in your specific phonegap/cordova application. So from a fresh
> > start, the process would be:
> >
> > 1. Generate a new Cordova Android application by running ./bin/create
> > <directory where new cordova app should reside> <package name>
> > <application name> (I.e. ./bin/create ~/src/myApp com.phonegap.myApp
> MyApp)
> > 2. Make some changes to the native code under the /framework dir.
> > 3. Cd into the /framework dir and run "ant jar".
> > 4. Copy cordova-1.5.0rc1.jar into the libs directory of your generated
> > project (I.e. cp cordova-1.5.0rc1.jar ~/src/myApp/libs/)
> >
> > On 3/1/12 5:02 PM, "Marlin Mixon" <marlin.mixon@gmail.com> wrote:
> >
> >>The only jar file I see in the repository is
> >>/framework/libs/commons-codec-1.3.jar
> >>So when I'm setting up my environment in Eclipse is that what I put in
> >>the libs directory?
> >>Compatred to PhoneGap 1.4 commons-codec-1.3.jar is a world apart from
> >>phonegap.jar.
> >>
> >>On Thu, Mar 1, 2012 at 6:32 PM, Joe Bowser <bowserj@gmail.com> wrote:
> >>> If you're getting the code from the repository, you shouldn't have to
> >>> update the project.  That's your problem.  Do a git reset and you
> >>>should be
> >>> good to go.
> >>>
> >>> BTW: I'm running 1.6.0_29, so it's not your Java version, especially
> >>>since
> >>> Google runs on 1.6 for ICS builds.
> >>>
> >>> Joe
> >>>
> >>> On Thu, Mar 1, 2012 at 4:17 PM, Marlin Mixon <marlin.mixon@gmail.com>
> >>>wrote:
> >>>
> >>>> I'm having an issue trying to generate the jar file.  I noticed a
> >>>> slight deviation of my setup as I'm running JDK 1.6.0_24 rather than
> >>>> 1.5 is that the problem?
> >>>>
> >>>> I've got the rest of the prerequisites. Here's what happens: Starting
> >>>> from a fresh pull from the incubator-cordova-android repository on
> >>>> github
> >>>>
> >>>> 1. cd to the framework directory and run
> >>>> android update project -p . -t android-15
> >>>>    I get:
> >>>> Updated project.properties
> >>>> Updated local.properties
> >>>> build.xml: Found version-tag: custom. File will not be updated.
> >>>> Added file ./proguard.cfg
> >>>>
> >>>> 2. run ant jar
> >>>>   I get:
> >>>> Buildfile: build.xml
> >>>>
> >>>> BUILD FAILED
> >>>> /home/marlin/incubator-cordova-android/framework/build.xml:56: The
> >>>> <property> type doesn't support nested text data (""").
> >>>>
> >>>> Total time: 0 seconds
> >>>>
> >>>> Any ideas?
> >>>>
> >>>> Thanks,
> >>>>
> >>>> Marlin
> >>>>
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message