incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marlin Mixon <marlin.mi...@gmail.com>
Subject Re: problem using jsdom in node
Date Thu, 01 Mar 2012 22:26:36 GMT
I think I have a theory why I was having problems with node.js 0.5.9
and 0.6.6.  When I initially installed npm I think I didn't have the
path set for any version of node.js.  So what worked was after
switching to node.js 0.6.6, by simply going back and running "npm
install" quickiy got the problem resolved.  So the theory is that npm
never got installed properly.  (Hope this helps others encountering
the same problem).

Marlin


On Thu, Mar 1, 2012 at 3:36 PM, Filip Maj <fil@adobe.com> wrote:
> FYI I had issues with Lion and node 0.6.10, I reverted to node 0.6.6 and
> that works good (documented that in the README)
>
> I just have the node source on my comp, checkout whatever tagged version I
> need, run ./configure, make, and make install. Symlink the node binary
> into /usr/local/bin and away you go.
>
> On 3/1/12 1:31 PM, "Marlin Mixon" <marlin.mixon@gmail.com> wrote:
>
>>For times like these I've found https://github.com/isaacs/nave to be
>>super useful.
>>Well, at least I've confirmed that node.js v0.6.11 doesn't work for
>>jake in the Linux environment either.  What version of node.js should
>>I be working with? (BTW, 0.6.11 is the version you get by default when
>>you go to download a fresh installation).  I've got nave installed so
>>I can easily install different versions and switch around.  I think
>>I'll try 0.5.9.
>>
>>On Tue, Feb 21, 2012 at 9:31 AM, Patrick Mueller <pmuellr@gmail.com>
>>wrote:
>>> On Tue, Feb 21, 2012 at 12:18, Josh Marinacci <joshua@marinacci.org>
>>>wrote:
>>>
>>>> I had this same issue and I was using a clean install. I don't know the
>>>> root cause but going back a few point revs fixed it.
>>>
>>>
>>> Looks like this is being tracked at the contextify github repo:
>>>
>>>    https://github.com/brianmcd/contextify/issues/19
>>>
>>> tl;dr: if you want to keep using contextify, which is used by jsdom,
>>>which
>>> is used by cordova-js `jake test` - DO NOT INSTALL NODE 0.6.11 (on Mac
>>> anyway)
>>>
>

Mime
View raw message