incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "lmnbeyond (Commented) (JIRA)" <>
Subject [jira] [Commented] (CB-260) Can't install Phonegap with new Xcode 4.3
Date Thu, 15 Mar 2012 08:59:38 GMT


lmnbeyond commented on CB-260:

Many thanks for Shazron Abdullah , St├ęphane Paquet and Tommy-Carlos Williams.
I'm a newbie to ios development. And My mother Language is not English, so if I wrote something
wrong, please forgive me :)

I downloaded the updated makefile, but it's still not work for me! 

My configuration is: os x 10.7.3  Xcode 4.3.1

I compiled the source code, it reported: " was not found. Please download from the
Mac App Store."  But I'm pretty sure I have installed xcode in my mac air.

xcode-select -print-path
The output is:/Applications/

So I followed St├ęphane Paquet's comments, modified XC_AVAILABLE and PM_APP,  make them point
to where my and is. After that, the source code is compiled sucessfully.

I hope my experience can help you!
> Can't install Phonegap with new Xcode 4.3
> -----------------------------------------
>                 Key: CB-260
>                 URL:
>             Project: Apache Callback
>          Issue Type: Bug
>          Components: iOS
>    Affects Versions: 1.4.0
>         Environment: OS X 10.7.3 (Lion)
>            Reporter: Kevin Walzer
>            Assignee: Shazron Abdullah
>            Priority: Critical
>              Labels: installer
>             Fix For: 1.6.0
>         Attachments:, Makefile, screenshot-1.jpg, screenshot-2.jpg,
> I've just updated my Xcode installation on Lion to 4.3, and now I cannot
> install the latest build of Phonegap 1.4.1: the installer says I do not have
> the iOS SDK installed.  Xcode 4.3 makes
> significant changes in the layout of the SDK's, etc. on OS X: it's a single
> standalone app that is installed in /Applications. /Developer is no longer
> used. I suspect that this confusing the installer. Most likely a re-architected installer
to support the new developer configuration in Xcode 4.3 is required. Obviously this is a showstopper
because I cannot develop a PhoneGap application if PhoneGap cannot be installed. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message