incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Filip Maj (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (CB-280) Improve layout of cordova-js scripts
Date Mon, 19 Mar 2012 17:45:39 GMT

    [ https://issues.apache.org/jira/browse/CB-280?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13232758#comment-13232758
] 

Filip Maj commented on CB-280:
------------------------------

I like the way this issue is shaping up. Will clean up cordova-js quite a bit.

That being said, is 1.6 too lofty a goal to land this?
                
> Improve layout of cordova-js scripts
> ------------------------------------
>
>                 Key: CB-280
>                 URL: https://issues.apache.org/jira/browse/CB-280
>             Project: Apache Callback
>          Issue Type: Improvement
>          Components: CordovaJS
>    Affects Versions: 1.5.0
>            Reporter: Filip Maj
>            Assignee: Filip Maj
>            Priority: Minor
>             Fix For: 1.6.0
>
>
> Originally proposed by Pat on the mailing list. Reorganize the directory names and conventions
used in the builder to make the association between javascript files and modules (and their
ids) clearer.
> From Pat's e-mail:
> - rename `~/lib` to `~/cordova`; there is no more `~/lib`.
> - mkdir ~/platform
> - mkdir ~/platform/android
> - mkdir ~/platform/...
> - move platform-specific stuff in ~/cordova (was ~/lib), in such a way as
> each module exists in a path associated with it's eventual module id,
> prefixed by `~/platform/[whicheverPlatform]`
> - move non-modules into a 'new' `~/lib` directory; it's more than just
> require.js - bootstrap, etc
> Now, to do a build for a platform:
> - collect as modules all files from ~/cordova
> - collect as modules all files from ~/platform/[whicheverPlatform]/cordova
> - collect as scripts all files from ~/lib
> bonusi:
> - the files are laid out exactly as the modules will be named, modulo
> platform-specific prefix directories for platform-specific files; no more
> in-head conversion when I'm looking at directory listings of modules.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message