incubator-callback-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Maj <...@adobe.com>
Subject Re: Geolocation override (content for README, doc update)
Date Wed, 22 Feb 2012 22:16:14 GMT
Shaz has kept a bunch of docs under the guide/ directory of the ios repo.
In there he has upgrade guides to 1.5 for plugins and for regular
projects. WE could follow that approach.

And yeah, moving forward the cordova-js approach of "forcing" the use of a
cordova plugin would be to use require syntax. You don't have to
explicitly assign it to any global variable, I.e. You can do:

require('cordova/plugin/geolocation').getCurrentPosition, or
require('cordova/plugin/geolocation').watchPosition


Etc.

Does that answer your q ?

On 12-02-22 1:44 PM, "Drew Walters" <deedubbu@gmail.com> wrote:

>Prior to cordova-js the end user could override the native browser
>implementation of navigator.geolocation with:
>
>    Geolocation.usePhoneGap()
>
>It appears to me that the way to do that with cordova-js would be:
>
>    navigator.geolocation = require('cordova/plugin/geolocation');
>
>Is that correct?  If so, we need to update docs.
>
>Do we have a location where we are keeping track of migration issues
>from 1.4 -> 1.5?


Mime
View raw message