incubator-callback-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From hermw...@apache.org
Subject [12/20] ios commit: Fixes CB-948 - Update Guides for 1.9.0
Date Wed, 27 Jun 2012 18:33:51 GMT
Fixes CB-948 - Update Guides for 1.9.0


Project: http://git-wip-us.apache.org/repos/asf/incubator-cordova-ios/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-cordova-ios/commit/79c0943a
Tree: http://git-wip-us.apache.org/repos/asf/incubator-cordova-ios/tree/79c0943a
Diff: http://git-wip-us.apache.org/repos/asf/incubator-cordova-ios/diff/79c0943a

Branch: refs/heads/master
Commit: 79c0943af994d9d6626f36d3691022d1c792a0f3
Parents: 5e9ff48
Author: Shazron Abdullah <shazron@apache.org>
Authored: Thu Jun 21 15:04:22 2012 -0700
Committer: hermwong <herm.wong@gmail.com>
Committed: Wed Jun 27 11:32:09 2012 -0700

----------------------------------------------------------------------
 guides/Cordova Plugin Upgrade Guide.md |    7 +++++++
 guides/Cordova Upgrade Guide.md        |   22 +++++++++++++++-------
 2 files changed, 22 insertions(+), 7 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-cordova-ios/blob/79c0943a/guides/Cordova
Plugin Upgrade Guide.md
----------------------------------------------------------------------
diff --git a/guides/Cordova Plugin Upgrade Guide.md b/guides/Cordova Plugin Upgrade Guide.md
index 5fef257..1cf0177 100644
--- a/guides/Cordova Plugin Upgrade Guide.md	
+++ b/guides/Cordova Plugin Upgrade Guide.md	
@@ -22,6 +22,13 @@
 
 This document is for developers who need to upgrade their Cordova  plugins to a newer Cordova
version. Starting with Cordova 1.5.0, some classes have been renamed, which will require the
plugin to be upgraded. Make sure your project itself has been upgraded using the "Cordova
Upgrade Guide" document.
 
+## Upgrading older Cordova plugins to 1.9.0 ##
+
+1. **Install** Cordova 1.9.0
+2. Follow the **"Upgrading older Cordova plugins to 1.8.0"** section, if necessary
+3. No changes in plugin structure from 1.8.x
+
+
 ## Upgrading older Cordova plugins to 1.8.0 ##
 
 1. **Install** Cordova 1.8.0

http://git-wip-us.apache.org/repos/asf/incubator-cordova-ios/blob/79c0943a/guides/Cordova
Upgrade Guide.md
----------------------------------------------------------------------
diff --git a/guides/Cordova Upgrade Guide.md b/guides/Cordova Upgrade Guide.md
index 5de3821..945449d 100644
--- a/guides/Cordova Upgrade Guide.md	
+++ b/guides/Cordova Upgrade Guide.md	
@@ -22,13 +22,21 @@
 
 This document is for developers who need to upgrade their Cordova-based projects to a newer
Cordova version. Starting with Cordova 1.4.0, Cordova has been re-factored to use Cleaver
(Cordova as a Component), and some classes that were used before have been removed - namely
PhoneGapDelegate and PhoneGapViewController.
 
-- To upgrade from 1.3.0 to 1.6.x, please go to the 1.4.0 instructions first, then 1.5.0,
then 1.6.x, then 1.7.0
-- To upgrade from 1.4.x to 1.6.x, please go to the 1.5.0 instructions first, then 1.6.x,
then 1.7.0
-- To upgrade from 1.5.0 to 1.7.0, please go to the 1.6.x instructions first, then 1.7.0
-- To upgrade from 1.6.x to 1.8.0, please go to the 1.7.x instructions first, then 1.8.0
-- To upgrade from 1.7.x to 1.8.0, go straight to the 1.8.0 instructions
+- To upgrade from 1.3.0 to 1.9.0, go through the 1.4.x, 1.5.0, 1.6.0, 1.7.x, 1.8.x then finally
the 1.9.0 instructions
+- To upgrade from 1.4.x to 1.9.0, go through the 1.5.0, 1.6.0, 1.7.x, 1.8.x then finally
the 1.9.0 instructions
+- To upgrade from 1.5.0 to 1.9.0, go through the 1.6.0, 1.7.x, 1.8.x then finally the 1.9.0
instructions
+- To upgrade from 1.6.0 to 1.9.0, go through the 1.7.x, 1.8.x then finally the 1.9.0 instructions
+- To upgrade from 1.7.x to 1.9.0, go through the 1.8.x then finally the 1.9.0 instructions
+- To upgrade from 1.8.x to 1.9.0, go through the 1.9.0 instructions
 
-## Upgrading Cordova 1.7.0 projects to 1.8.0 ##
+## Upgrading Cordova 1.8.x projects to 1.9.0 ##
+
+1. **Install** Cordova 1.8.0
+2. **Create a new project** - you will have to grab assets from this new project
+3. **Copy** the **www/cordova-1.9.0.js** file from the new project into your **www** folder,
and delete your **www/cordova-1.8.x.js** file
+4. **Update** the Cordova script reference in your **www/index.html** file (and any other
files that contain the script reference) to point to the new **cordova-1.9.0.js** file
+
+## Upgrading Cordova 1.7.0 projects to 1.8.x ##
 
 1. **Install** Cordova 1.8.0
 2. **Create a new project** - you will have to grab assets from this new project
@@ -42,7 +50,7 @@ If you intend on using the **Capture API**, you will need the new **iPad
retina-
 3.  Drag the new **Capture.bundle** from Step 1. above into Xcode into your Project Navigator,
and select the **Create groups for any added folders** radio-button
    
 
-## Upgrading Cordova 1.6.0 projects to 1.7.0 ##
+## Upgrading Cordova 1.6.x projects to 1.7.0 ##
 
 1. **Install** Cordova 1.7.0
 2. **Create a new project** - you will have to grab assets from this new project


Mime
View raw message