incubator-callback-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bows...@apache.org
Subject [2/2] docs commit: Updated the migration guide for Android. Still needs to be fleshed out, but this is it
Date Wed, 13 Jun 2012 17:14:56 GMT
Updated the migration guide for Android.  Still needs to be fleshed out, but this is it


Project: http://git-wip-us.apache.org/repos/asf/incubator-cordova-docs/repo
Commit: http://git-wip-us.apache.org/repos/asf/incubator-cordova-docs/commit/6ece7d5e
Tree: http://git-wip-us.apache.org/repos/asf/incubator-cordova-docs/tree/6ece7d5e
Diff: http://git-wip-us.apache.org/repos/asf/incubator-cordova-docs/diff/6ece7d5e

Branch: refs/heads/master
Commit: 6ece7d5ef2b299f4a128ea39186d48f60c4e79a9
Parents: f84d5a7
Author: Joe Bowser <bowserj@apache.org>
Authored: Wed Jun 13 10:12:29 2012 -0700
Committer: Joe Bowser <bowserj@apache.org>
Committed: Wed Jun 13 10:12:29 2012 -0700

----------------------------------------------------------------------
 docs/en/edge/guide/upgrading/android/index.md |   74 +++++++++++++++++++-
 1 files changed, 71 insertions(+), 3 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/incubator-cordova-docs/blob/6ece7d5e/docs/en/edge/guide/upgrading/android/index.md
----------------------------------------------------------------------
diff --git a/docs/en/edge/guide/upgrading/android/index.md b/docs/en/edge/guide/upgrading/android/index.md
index c818869..b12a674 100644
--- a/docs/en/edge/guide/upgrading/android/index.md
+++ b/docs/en/edge/guide/upgrading/android/index.md
@@ -24,7 +24,8 @@ Upgrading Cordova Android
 This document is for people who need to upgrade their Cordova versions from an older version
to a current version of Cordova.
 
 - To upgrade to 1.8.0, please go from 1.7.0
-- To upgrade from 1.7.0, please go from 1.6.0
+- To upgrade to 1.7.0, please go from 1.6.0
+- To upgrade to 1.0.0, please go from 0.9.6
 
 ## Upgrade to 1.8.0 from 1.7.0 ##
 
@@ -41,7 +42,74 @@ This document is for people who need to upgrade their Cordova versions
from an o
 1. Remove cordova-1.6.0.jar from the libs directory in your project
 2. Add cordova-1.6.0.jar to the libs directory in your project
 3. If you are using Eclipse, please refresh your eclipse project and do a clean
-4. Copy the new cordova-1.6.0.js into your project
-5. Update your HTML to sue the new cordova-1.6.0.js file
+4. Copy the new cordova-1.7.0.js into your project
+5. Update your HTML to use the new cordova-1.6.0.js file
 6. Update the res/xml/plugins.xml to be the same as the one found in framework/res/xml/plugins.xml
 
+# Upgrade to 1.6.0 from 1.5.0
+1. Remove cordova-1.5.0.jar from the libs directory in your project
+2. Add cordova-1.6.0.jar to the libs directory in your project
+3. If you are using Eclipse, please refresh your eclipse project and do a clean
+4. Copy the new cordova-1.6.0.js into your project
+5. Update your HTML to use the new cordova-1.6.0.js file
+6. Update the res/xml/plugins.xml so that it is the same as the one found in framework/res/xml/plugins.xml
+7. Replace the res/xml/phonegap.xml with res/xml/cordova.xml so that it is the same as the
one found in framework/res/xml/cordova.xml
+
+
+# Upgrade to 1.5.0 from 1.4.0
+1. Remove phonegap-1.4.0.jar from the libs directory in your project
+2. Add cordova-1.5.0.jar to the libs directory in your project
+3. If you are using Eclipse, please refresh your eclipse project and do a clean
+4. Copy the new cordova-1.5.0.js into your project
+5. Update your HTML to use the new cordova-1.5.0.js file
+6. Update the res/xml/plugins.xml so that it is the same as the one found in framework/res/xml/plugins.xml
+7. Replace the res/xml/phonegap.xml with res/xml/cordova.xml so that it is the same as the
one found in framework/res/xml/cordova.xml
+
+# Upgrade to 1.4.0 from 1.3.0
+1. Remove phonegap-1.3.0.jar from the libs directory in your project
+2. Add phonegap-1.4.0.jar to the libs directory in your project
+3. If you are using Eclipse, please refresh your eclipse project and do a clean
+4. Copy the new phonegap-1.4.0.js into your project
+5. Update your HTML to use the new phonegap-1.4.0.js file
+6. Update the res/xml/plugins.xml so that it is the same as the one found in framework/res/xml/plugins.xml
+7. Update the res/xml/phonegap.xml so that it is the same as the one found in framework/res/xml/phonegap.xml
+
+
+# Upgrade to 1.3.0 from 1.2.0
+1. Remove phonegap-1.2.0.jar from the libs directory in your project
+2. Add phonegap-1.3.0.jar to the libs directory in your project
+3. If you are using Eclipse, please refresh your eclipse project and do a clean
+4. Copy the new phonegap-1.3.0.js into your project
+5. Update your HTML to use the new phonegap-1.2.0.js file
+6. Update the res/xml/plugins.xml so that it is the same as the one found in framework/res/xml/plugins.xml
+7. Update the res/xml/phonegap.xml so that it is the same as the one found in framework/res/xml/phonegap.xml
+
+
+# Upgrade to 1.2.0 from 1.1.0
+1. Remove phonegap-1.1.0.jar from the libs directory in your project
+2. Add phonegap-1.2.0.jar to the libs directory in your project
+3. If you are using Eclipse, please refresh your eclipse project and do a clean
+4. Copy the new phonegap-1.2.0.js into your project
+5. Update your HTML to use the new phonegap-1.2.0.js file
+6. Update the res/xml/plugins.xml so that it is the same as the one found in framework/res/xml/plugins.xml
+7. Update the res/xml/phonegap.xml so that it is the same as the one found in framework/res/xml/phonegap.xml
+
+
+# Upgrade to 1.1.0 from 1.0.0
+1. Remove phonegap-1.0.0.jar from the libs directory in your project
+2. Add phonegap-1.1.0.jar to the libs directory in your project
+3. If you are using Eclipse, please refresh your eclipse project and do a clean
+4. Copy the new phonegap-1.1.0.js into your project
+5. Update your HTML to use the new phonegap-1.1.0.js file
+6. Update the res/xml/plugins.xml so that it is the same as the one found in framework/res/xml/plugins.xml
+
+
+# Upgrade to 1.0.0 from 0.9.6
+1. Remove phonegap-0.9.6.jar from the libs directory in your project
+2. Add phonegap-1.0.0.jar to the libs directory in your project
+3. If you are using Eclipse, please refresh your eclipse project and do a clean
+4. Copy the new phonegap-1.0.0.js into your project
+5. Update your HTML to use the new phonegap-1.0.0.js file
+6. Add the res/xml/plugins.xml so that it is the same as the one found in framework/res/xml/plugins.xml
+
+


Mime
View raw message