incubator-bval-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Nuttall <mnutt...@apache.org>
Subject Re: Please consider versioning your exported packages
Date Mon, 15 Nov 2010 15:53:59 GMT
Hi Donald,
I know that we need to have a similar discussion within the Apache
Aries project. I'm expecting that we'll start proper semantic
versioning once we graduate and put out a 1.0 release. That means that
pulling in those bundles, we have a number of potentially unstable
package imports of the form ;version="[0.3.0,2.0.0)". It's not ideal
but still better than nothing. Do please let us know the outcome of
any dev-list discussion on the subject. Thank you!

Regards,
Mark

On 12 November 2010 19:23, Donald Woods <dwoods@apache.org> wrote:
> My thoughts, were to add versions once we leave the Apache Incubator and
> become a TLP....
>
> We could add them before then, but I've seen other groups/projects run
> into issues with correctly using versions.  Maybe we should start a
> discussion on the dev list.
>
>
> -Donald
>
>
> On 11/12/10 9:13 AM, Mark Nuttall wrote:
>> Hello,
>> Thank you all for your work on the Apache Bean Validation project.
>>
>> I've just downloaded "Apache Bean Validation provider w/ OSGi metadata
>> (contains bval-core and bval-jsr303)" from your website. While the
>> bundle's manifest includes the use of 'uses' and 'resolution'
>> directives, I notice that you're not yet providing some of the most
>> basic OSGi metadata: versions on your exported packages.
>>
>> May I ask, please, whether your team yet has a plan to begin
>> versioning the packages exported by your bundles? It would be of great
>> assistance to the project I'm working on if you would. Thank you!
>>
>> Regards,
>> Mark
>>
>

Mime
View raw message