incubator-blur-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron McCurry <amccu...@gmail.com>
Subject Re: Can't compile 0.1.3, 0.1.4 branch due to missing dep lucene-core 3.6.1.lm
Date Tue, 01 Jan 2013 21:55:10 GMT
Yes it's a custom version of Lucene 3.6.1, the jar plus patch should be
located in the src/lib/org/apache/lucene/lucene-core/3.6.1.lm path.  The
maven pom should reference this path, not sure what the problem could be.
 Let me know if there's something else I can do to help you get through
this compiling issue.  Also, the patched version is not required.  It's
only a performance optimization to reduce GC pause times.

https://git-wip-us.apache.org/repos/asf?p=incubator-blur.git;a=tree;f=src/lib/org/apache/lucene/lucene-core/3.6.1.lm;h=d2bc764ca447c9e3253a57048ee0d634ca296596;hb=0.1.4-final

Thanks,

Aaron


On Tue, Jan 1, 2013 at 4:43 PM, James Kebinger <jkebinger@gmail.com> wrote:

> Please forgive this dumb question, but I can't compile either of the
> mentioned branches because they depend on a version of lucene that doesn't
> appear to exist in the wild. I checked the obvious places like
> http://mvnrepository.com/
>
> Is this a custom build of lucene with some patches applied?
>
> <dependency>
>   <groupId>org.apache.lucene</groupId>
>   <artifactId>lucene-core</artifactId>
>   <version>3.6.1.lm</version>
> </dependency>
>
> Thanks
>
> -James
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message