incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From prince shah <shahprin...@gmail.com>
Subject Re: BLUR-440
Date Fri, 14 Aug 2015 22:24:24 GMT
Hi Aaron,

I did "mvn eclipse:eclipse -Dhadoop2"

I see no .classpath or .project file for eclipse :(

[INFO] Building Distribution hadoop2-2.6.0-0.2.4-incubating-SNAPSHOT
[INFO]
------------------------------------------------------------------------
[WARNING] The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is
missing, no dependency information available
[WARNING] Failed to retrieve plugin descriptor for
org.eclipse.m2e:lifecycle-mapping:1.0.0: Plugin
org.eclipse.m2e:lifecycle-mapping:1.0.0 or one of its dependencies could
not be resolved: Failed to read artifact descriptor for
org.eclipse.m2e:lifecycle-mapping:jar:1.0.0
[INFO]



On Fri, Aug 14, 2015 at 1:42 PM, Aaron McCurry <amccurry@gmail.com> wrote:

> For every mvn command you need to include the -Dhadoop2 profile.  Give that
> a try and let us know.  Thanks!
>
> Aaron
>
> On Fri, Aug 14, 2015 at 11:52 AM, prince shah <shahprincea@gmail.com>
> wrote:
>
> > I did following to build Blur source code:
> >
> > *Dev environment: *
> >
> > 1. Ubuntu 14.04.3 LTS
> > 2. git version 1.9.1
> > 3. MVN version 3.13.0-61-generic
> > 4. java version "1.8.0_51"
> >
> >
> >
> > *Steps: *
> > 1. sudo apt-get update
> > 2. ssh localhost (if failed follow 3 and 4 below else jump to 5)
> > 3. ssh-keygen -t dsa -P '' -f ~/.ssh/id_dsa
> > 4. cat ~/.ssh/id_dsa.pub >> ~/.ssh/authorized_keys
> > 5. mkdir /home/teneo/Desktop/blur (bascially create dir where blur source
> > code will be checked out)
> > 6. git clone https://git-wip-us.apache.org/repos/asf/incubator-blur.git
> > 7. cd /home/teneo/Desktop/blur/incubator-blur
> > 8. mvn install -DskipTests -Dhadoop2 (If all goes well you should see
> BUILD
> > SUCCESS)
> > 9. mvn eclipse:eclipse
> >
> > You will see following error:
> >
> > [INFO] Scanning for projects...
> > [WARNING]
> > [WARNING] Some problems were encountered while building the effective
> model
> > for org.apache.blur:blur:pom:0.2.4-incubating-SNAPSHOT
> > *[WARNING] 'reporting.plugins.plugin.version' for
> > org.apache.maven.plugins:maven-javadoc-plugin is missing. @ line 480,
> > column 12*
> > [WARNING]
> > [WARNING] It is highly recommended to fix these problems because they
> > threaten the stability of your build.
> > [WARNING]
> > [WARNING] For this reason, future Maven versions might no longer support
> > building such malformed projects.
> > [WARNING]
> > *[WARNING] The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is
> > missing, no dependency information available*
> > [WARNING] Failed to retrieve plugin descriptor for
> > org.eclipse.m2e:lifecycle-mapping:1.0.0: Plugin
> > org.eclipse.m2e:lifecycle-mapping:1.0.0 or one of its dependencies could
> > not be resolved: Failed to read artifact descriptor for
> > org.eclipse.m2e:lifecycle-mapping:jar:1.0.0
> > [INFO]
> >
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Building Blur 0.2.4-incubating-SNAPSHOT
> > [INFO]
> > ------------------------------------------------------------------------
> > [WARNING] The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is
> > missing, no dependency information available
> > [WARNING] Failed to retrieve plugin descriptor for
> > org.eclipse.m2e:lifecycle-mapping:1.0.0: Plugin
> > org.eclipse.m2e:lifecycle-mapping:1.0.0 or one of its dependencies could
> > not be resolved: Failed to read artifact descriptor for
> > org.eclipse.m2e:lifecycle-mapping:jar:1.0.0
> > [INFO]
> > [INFO] >>> maven-eclipse-plugin:2.10:eclipse (default-cli) @ blur >>>
> > [INFO]
> > [INFO] --- maven-remote-resources-plugin:1.5:process (default) @ blur ---
> > [INFO]
> > [INFO] <<< maven-eclipse-plugin:2.10:eclipse (default-cli) @ blur <<<
> > [INFO]
> > [INFO] --- maven-eclipse-plugin:2.10:eclipse (default-cli) @ blur ---
> > [INFO] Not running eclipse plugin goal for pom project
> > [INFO] Using Eclipse Workspace: null
> > [INFO] Adding default classpath container:
> >
> >
> org.eclipse.jdt.launching.JRE_CONTAINER/org.eclipse.jdt.internal.debug.ui.launcher.StandardVMType/JavaSE-1.6
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] BUILD SUCCESS
> > [INFO]
> > ------------------------------------------------------------------------
> > [INFO] Total time: 1.080s
> > [INFO] Finished at: Fri Aug 14 08:25:00 PDT 2015
> > [INFO] Final Memory: 18M/175M
> > [INFO]
> > ------------------------------------------------------------------------
> >
> >
> > I tried following but no luck so far :(
> >
> > a. edit pom.xml file in incubator-blur folder. Go to line 482 (look
> > for maven-javadoc-plugin) and add version number.
> >
> > b. mvn archetype:generate -DgroupId=org.eclipse.m2e
> > -DartifactId=lifecycle-mapping -Dversion=1.0.0
> > -DarchetypeArtifactId=maven-archetype-mojo
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message