incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Rohr <rohr.ch...@gmail.com>
Subject Re: Controller Server not starting in Latest Blur 0.2.4
Date Thu, 18 Dec 2014 11:28:54 GMT
Great thank you. I will take a look today.
On Thu, Dec 18, 2014 at 5:53 AM Dibyendu Bhattacharya <
dibyendu.bhattachary@gmail.com> wrote:

> Hi,
>
> I did "mvn install -DskipTests -Dhadoop1" to build Blur.
>
> Dibyendu
>
> On Thu, Dec 18, 2014 at 4:15 PM, Chris Rohr <rohr.chris@gmail.com> wrote:
> >
> > Dibyendu,
> >
> > Thank you for the heads up. To make it easier to track, which profile did
> > you use to build blur?
> >
> > Thanks,
> > Chris
> > On Thu, Dec 18, 2014 at 4:24 AM Dibyendu Bhattacharya <
> > dibyendu.bhattachary@gmail.com> wrote:
> >
> > > Hi,
> > >
> > > I have downloaded latest Blur 0.2.4 today and I found Controller server
> > is
> > > not starting and I can see below log trace..
> > >
> > > java.lang.NoClassDefFoundError: javax/servlet/HttpConstraintElement
> > >         at
> > > org.apache.blur.gui.HttpJettyServer.<init>(HttpJettyServer.java:57)
> > >         at
> > > org.apache.blur.thrift.ThriftBlurControllerServer.createServer(
> > > ThriftBlurControllerServer.java:218)
> > >         at
> > > org.apache.blur.thrift.ThriftBlurControllerServer.main(
> > > ThriftBlurControllerServer.java:96)
> > > Caused by: java.lang.ClassNotFoundException:
> > > javax.servlet.HttpConstraintElement
> > >         at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
> > >         at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
> > >         at java.security.AccessController.doPrivileged(Native Method)
> > >         at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
> > >         at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
> > >         at sun.misc.Launcher$AppClassLoader.loadClass(
> Launcher.java:308)
> > >         at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
> > >         ... 3 more
> > >
> > >
> > >
> > > This is because the servlet-api jar file is missing in lib folder. I
> > > manually copied the servlet-api jar and then controller is getting
> > started.
> > >
> > > You may need to modify the pom file to fix this issue.
> > >
> > > Regards,
> > > Dibyendu
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message