incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron McCurry <amccu...@gmail.com>
Subject Re: Weird compile error
Date Sat, 01 Nov 2014 20:39:26 GMT
Ok. Glad you figured it out. Thanks for letting us know the solution.

Aaron

On Saturday, November 1, 2014, Chris Rohr <rohr.chris@gmail.com> wrote:

> Nevermind this email.  For some reason the jetty pom that was downloaded
> didn't have it's dependencies for some reason which caused my compile
> problems.  I deleted the local repo and it re-downloaded correctly and
> compiled.
>
> Chris
>
> On Sat Nov 01 2014 at 2:06:43 PM Chris Rohr <rohr.chris@gmail.com
> <javascript:;>> wrote:
>
> > Hi all,
> >
> > I'm having a weird compile error with the current code on master and I'm
> > hoping someone can shed some light.  I recently have had to start with a
> > clean local maven repo and ever since, blur-core won't compile on any
> > profile.  It seems that it can't find jetty for the ThriftServer code.
> > Also I do not have any of Andrew's branch refactoring the dependency
> > management for blur.  Below is the output from mvn clean install
> > -Dhadoop2-mr1:
> >
> > [ERROR] COMPILATION ERROR :
> >
> > [INFO] -------------------------------------------------------------
> >
> > [ERROR]
> >
> /Users/crohr/Projects/opensource/incubator-blur/blur-core/src/main/java/org/apache/blur/thrift/ThriftBlurShardServer.java:[278,25]
> > cannot find symbol
> >
> > symbol  : constructor
> > ServletHolder(org.apache.blur.gui.JSONReporterServlet)
> >
> > location: class org.mortbay.jetty.servlet.ServletHolder
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message