incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Garrett Barton (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BLUR-316) Blur Shell not handling backslashes properly
Date Wed, 04 Dec 2013 16:25:37 GMT

    [ https://issues.apache.org/jira/browse/BLUR-316?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13839045#comment-13839045
] 

Garrett Barton commented on BLUR-316:
-------------------------------------

Yes \ is an escape character, so if I enter into the console:
query mytable cf.col:foo\bar
I get no backslash by the time it gets to the shards. Using up arrow also will not have a
'\' in the query anymore.
If I enter:
query mytable cf.col:foo\\bar
I still get no backslash in the shards, up arrow in the console will show a single '\' this
time.

I think the console is eating one, probably reading the command line in as a string I'd guess.
 My custom Field Type spits out the query it gets, and from the console I can not get it to
receive a backslash '\'.

> Blur Shell not handling backslashes properly
> --------------------------------------------
>
>                 Key: BLUR-316
>                 URL: https://issues.apache.org/jira/browse/BLUR-316
>             Project: Apache Blur
>          Issue Type: Bug
>          Components: Blur
>    Affects Versions: 0.2.2
>            Reporter: Garrett Barton
>
> If I have a field that has backslash delimited text within it I cannot query this from
the blur shell. (Yes I have an analyzer to handle it)
> Simplest test is to fire a query and then up arrow, and you will notice that the \ is
gone from the previous query.



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message