incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Upender Nimbekar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BLUR-313) Let Blur run against CDH4/Hadoop 2.x
Date Mon, 30 Dec 2013 22:43:50 GMT

    [ https://issues.apache.org/jira/browse/BLUR-313?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13859146#comment-13859146
] 

Upender Nimbekar commented on BLUR-313:
---------------------------------------

I was able to get rid of this issue. Also, I was able to apply the patch but only MANUALLY.
"Git apply ...." showed error. Probably because I tried to apply the patch for Blur 0.2.2
version rather than 0.2.0. Anyway, continuing, after installing Maving 3.X, and making all
the necessary changes, I tried to build blur using (as Garrett mentioned):
   mvn clean package install -P hadoop-1x, cdh4-mr1 -Dhadoop.version=2.0.0-mr1-cdh4.5.0 -DskipTests=true
  (I changed it from 4.3 to 4.5 as I ahve cdh4.5 installed)

But it is failing while building the blur-util. 

[ERROR]: Failed to execute goal on project blur-util: could not resolve dependencies for project
org.apache.blur:blur-util:jar:0.2.2-incubating-SNAPSHOT: Failed to collect dependencies for
[Org.apache.zookeeper:zookeeper:jar:3.4.5 (compile)......., org.apache.hadoop:hadoop-core:jar:2.0.0-mr1-cdh4.5.0
(etc).........list goes on...

Let me know what am I missing ...

Simply doing mvn compile works.

I have checked that my blur-config.sh and blur-env.sh has all the changes as mentioned in
the patch.

> Let Blur run against CDH4/Hadoop 2.x
> ------------------------------------
>
>                 Key: BLUR-313
>                 URL: https://issues.apache.org/jira/browse/BLUR-313
>             Project: Apache Blur
>          Issue Type: Bug
>          Components: Blur
>    Affects Versions: 0.3.0, 0.2.2
>            Reporter: Garrett Barton
>         Attachments: hadoop-2.x-partial-fix.patch
>
>
> This is a partial fix for getting blur to run against Hadoop 2.x/CDH4.  I modded blur-env.sh
and blur-config.sh to add optional params for locating the now dispersed hadoop distribution.
 CDH3/Hadoop 1.x should still work as before.
> I say partial fix because I fail miserably at getting blur-gui to add in ant-1.6.5 to
the dependencies that get packaged up in blur's lib folder.  That is all that's left to run
blur.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message