incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hunter Williams <hunter.willi...@bti360.com>
Subject Re: Problems Getting Started with Table Creation
Date Wed, 11 Sep 2013 18:01:11 GMT
Aaron,

I disabled and removed all existing tables and restarted in case any
process was lingering. I created a table with a name & location I had not
tried previously.

I ran this command: create -t newtesttable -c 11 -l
file:///data/newtesttable
Got: IOException Table Already exists

Console and logs are attached.


Thanks,

Hunter



On Wed, Sep 11, 2013 at 1:39 PM, Aaron McCurry <amccurry@gmail.com> wrote:

> Hey Hunter,
>
> First off welcome to the community.  Let me start by asking a couple of
> debugging questions.
>
> After you run that command, if you run "list" is testtable3 in the list?
>
> Also are there are any tables in the list?  If there are make sure that
> none of them are also using the "file:///data/testtable3" location.  If
> they are that may be your problem.  If this was a unique name problem then
> Blur would likely throw a blurexception and fail immediately.  But since
> it's an ioexception my guess is there's another table using that path.
>  Blurexceptions are not tried but any other exceptions are retried a few
> times which might explain the 15 second delay.
>
> For debugging you can run "debug" in the shell to toggle the stack traces
> on and off.
>
> You also might want to take a look at the controller and shard log files
> found in the $BLUR_HOME/logs directory.
>
> Let us know what you find and we can go from there.
>
> Thanks,
>
> Aaron
>
>
>
> On Wed, Sep 11, 2013 at 12:52 PM, Hunter Williams <
> hunter.williams@bti360.com> wrote:
>
> > I'm just getting started and working through the quick start.
> >
> > Every time I attempt to create a table it takes upwards of 15 seconds if
> > not longer before giving me this exception
> >
> > blur (default)> create -t testtable3 -c 11 -l file:///data/testtable3
> > > java.io.IOException: Table [testtable3] already exists.
> > >
> >
> > I've attempted changing table and location names as well as the chard
> count
> > to 1.
> >
> > I'm running Ubuntu 13 with openjdk 6 in a Virtualbox. I'm compiling from
> > the repo.
> >
> >
> > Thanks,
> >
> > Hunter
> >
> > --
> >
> > Hunter G. Williams
> >
> > 804-314-7499 | www.BTI360.com <http://www.bti360.com/>
> >
>



-- 

Hunter G. Williams

804-314-7499 | www.BTI360.com <http://www.bti360.com/>

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message