incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tim Williams <william...@gmail.com>
Subject Re: Trouble Building 0.2
Date Thu, 11 Jul 2013 16:27:48 GMT
It looks like you're running that from the source directory?  you
should be untarring the distro to some install location and running
from there.  or, perhaps i'm rading that wrong...  did you follow the
wiki getting started?

http://wiki.apache.org/blur/PseudoDistributed

--tim

On Thu, Jul 11, 2013 at 12:22 PM,  <development@the10thfloor.com> wrote:
> Hi Gagan,
>
> This did get me a little further.  Now, I'm told that ZooKeeper, Shard,
> and Controller are starting but they really don't.
>
> Below is the output of the blur-zk, blur-shard, and blur-controller log
> files.
>
> Thanks for the help!
>
>
> -----
>
>
> [root@db3 logs]#
> /opt/incubator-blur/distribution/src/main/scripts/bin/start-all.sh
> localhost: ZooKeeper starting as process 23388.
> localhost: Shard [0] starting as process 23446.
> localhost: Controller [0] starting as process 23503.
>
> [root@db3 logs]# cat blur-zk-*.out
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/zookeeper/server/quorum/QuorumPeerMain
> Caused by: java.lang.ClassNotFoundException:
> org.apache.zookeeper.server.quorum.QuorumPeerMain
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> Could not find the main class:
> org.apache.zookeeper.server.quorum.QuorumPeerMain.  Program will exit.
>
> [root@db3 logs]# cat blur-shard*.out
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/blur/thrift/ThriftBlurShardServer
> Caused by: java.lang.ClassNotFoundException:
> org.apache.blur.thrift.ThriftBlurShardServer
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> Could not find the main class:
> org.apache.blur.thrift.ThriftBlurShardServer.  Program will exit.
>
> [root@db3 logs]# cat blur-controller*.out
> Exception in thread "main" java.lang.NoClassDefFoundError:
> org/apache/blur/thrift/ThriftBlurControllerServer
> Caused by: java.lang.ClassNotFoundException:
> org.apache.blur.thrift.ThriftBlurControllerServer
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> Could not find the main class:
> org.apache.blur.thrift.ThriftBlurControllerServer.  Program will exit.
> [root@db3 logs]#
>
>
>
>> Hi,
>> Can you please create a file named "zookeepers" with the content of
>> your zookeeper host name like localhost. And put this file in conf
>> directory of blur.
>>
>> Let us know if it works I will raise an issue to fix this.
>>
>> Regards,
>> Gagan
>>
>> On Thu, Jul 11, 2013 at 10:20 AM,  <development@the10thfloor.com> wrote:
>>> Unfortunately, while the skiptest flag worked to get installed, I still
>>> can't start blur.
>>>
>>> I get the following error:
>>> cat:
>>> /opt/incubator-blur/distribution/src/main/scripts/bin/../conf/zookeepers:
>>> No such file or directory
>>>
>>> The full installation log is here:
>>> http://pastebin.com/GVPABsM9
>>>
>>> My zookeeper install is via CH4.  Is this an issue here?
>>>
>>> Thanks,
>>>
>>> slevytam
>>>
>>>
>>>> Looks like the bind port for tests is failing. There must be another
>>>> process already bound on that port on your machine.  We should change
>>>> that
>>>> address to be random in the test.  I will try to take look at it
>>>> tomorrow.
>>>> In the meantime if you want to run blur yes you should disable the
>>>> tests.
>>>>
>>>> Aaron
>>>>
>>>> Sent from my iPad
>>>>
>>>> On Jul 10, 2013, at 12:37 PM, development@the10thfloor.com wrote:
>>>>
>>>>> Unfortunately, I get the same error with the master branch.  I've
>>>>> pasted
>>>>> my install log here: http://pastebin.com/gfzYxvr0
>>>>>
>>>>> Should I be using -DskipTests on the mvn install command?
>>>>>
>>>>> Thanks,
>>>>>
>>>>> slevytam
>>>>>
>>>>>
>>>>>
>>>>>> Yes, that branch is a work in progress.  Please try the master branch
>>>>>> for
>>>>>> trying out 0.2.  Once that branch is working it will be merge into
>>>>>> master.
>>>>>>
>>>>>> Aaron
>>>>>>
>>>>>>
>>>>>> On Wed, Jul 10, 2013 at 1:52 AM, <development@the10thfloor.com>
>>>>>> wrote:
>>>>>>
>>>>>>> Hello,
>>>>>>>
>>>>>>> I'm trying to give Blur a look but I am having trouble building
from
>>>>>>> git
>>>>>>> checkout 0.2.0-newtypesystem.
>>>>>>>
>>>>>>> I've attached the maven install log below.  It appears that there
is
>>>>>>> some
>>>>>>> "address already in use" issue with zookeeper.
>>>>>>>
>>>>>>> Any help would be appreciated.
>>>>>>>
>>>>>>> Thanks,
>>>>>>>
>>>>>>> slevytam
>>>>>>>
>>>>>>> -----------------------------------------
>>>>>>>
>>>>>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: Server
>>>>>>> environment:user.name=root
>>>>>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: Server
>>>>>>> environment:user.home=/root
>>>>>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: Server
>>>>>>> environment:user.dir=/opt/incubator-blur/blur-util
>>>>>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: tickTime set to
2000
>>>>>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: minSessionTimeout
set
>>>>>>> to
>>>>>>> -1
>>>>>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: maxSessionTimeout
set
>>>>>>> to
>>>>>>> -1
>>>>>>> 13/07/10 05:43:43 INFO server.NIOServerCnxnFactory: binding to
port
>>>>>>> 0.0.0.0/0.0.0.0:10101
>>>>>>> 13/07/10 05:43:43 ERROR server.ZooKeeperServerMain: Unexpected
>>>>>>> exception,
>>>>>>> exiting abnormally
>>>>>>> java.net.BindException: Address already in use
>>>>>>>        at sun.nio.ch.Net.bind(Native Method)
>>>>>>>        at
>>>>>>> sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:137)
>>>>>>>        at
>>>>>>> sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77)
>>>>>>>        at
>>>>>>> sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:70)
>>>>>>>        at
>>>>>>>
>>>>>>> org.apache.zookeeper.server.NIOServerCnxnFactory.configure(NIOServerCnxnFactory.java:95)
>>>>>>>        at
>>>>>>>
>>>>>>> org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:110)
>>>>>>>        at
>>>>>>>
>>>>>>> org.apache.zookeeper.server.ZooKeeperServerMain.initializeAndRun(ZooKeeperServerMain.java:86)
>>>>>>>        at
>>>>>>>
>>>>>>> org.apache.zookeeper.server.ZooKeeperServerMain.main(ZooKeeperServerMain.java:52)
>>>>>>>        at
>>>>>>>
>>>>>>> org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:116)
>>>>>>>        at
>>>>>>>
>>>>>>> org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:78)
>>>>>>>        at
>>>>>>> org.apache.blur.zookeeper.ZkUtilsTest$1.run(ZkUtilsTest.java:51)
>>>>>>>        at java.lang.Thread.run(Thread.java:679)
>>>>>>>
>>>>>>> Results :
>>>>>>>
>>>>>>> Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
>>>>>>>
>>>>>>> [INFO]
>>>>>>> ------------------------------------------------------------------------
>>>>>>> [INFO] Reactor Summary:
>>>>>>> [INFO]
>>>>>>> [INFO] Blur .............................................. SUCCESS
>>>>>>> [1.143s]
>>>>>>> [INFO] Blur Util ......................................... FAILURE
>>>>>>> [1.029s]
>>>>>>>
>>>>>>
>>>>
>>>
>>
>

Mime
View raw message