incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron McCurry <amccu...@gmail.com>
Subject Re: Trouble Building 0.2
Date Sat, 13 Jul 2013 22:31:13 GMT
On Sat, Jul 13, 2013 at 10:19 AM, Tim Williams <williamstw@gmail.com> wrote:

> On Fri, Jul 12, 2013 at 1:40 AM,  <development@the10thfloor.com> wrote:
> > Hi Tim,
> >
> > I'm slowing making progress.  Got the target built now correctly and now
> I
> > can start the controller and shard.
> >
> > Unfortunately, I'm still now sure how this should be configured with my
> > zookeeper install.  I modified
> > /opt/apache-blur-0.2.0-incubating-SNAPSHOT/bin/../conf/zookeepers with
> the
> > zookeeper host ie. (localhost) for now.  However, the zookeeper log gives
> > me a config error when reading default_zoo.cfg. That makes sense as the
> > file does not exist.
>
> Hmm... actually, I'm not sure - honestly I've always had an
> independent zookeeper - never a Blur managed one (this is apparently a
> new thing as of last month).   I'm guessing that feature just isn't
> fully baked yet and is missing the zoo config file.  So, I reckon
> there are two choices - use your own zookeeper install if you have
> one; or, download zoo_sample.cfg[1], drop it in the conf directory and
> rename it to default_zoo.cfg - maybe that will work?
>

So sorry about that.  The 2 files needed conf/zookeepers and
conf/default_zoo.cfg were being excluded was of .gitignore.  So I missed
them when I was checking in that feature.

I have checked in those missing files:

https://git-wip-us.apache.org/repos/asf?p=incubator-blur.git;a=tree;f=distribution/src/main/scripts/conf;hb=HEAD

But as Tim suggested running a dedicated ZK cluster is normal operation.
 This type of deployment is really just there to help get things going
faster.  Obviously it didn't this time, but hopefully it will for other now.


>
> > I am able to successfully create a table on the local filesystem;
> however,
> > when trying to create a table in hdfs it appears as though it's not
> > compatible with Hadoop 2.0
> >
> > "org.apache.hadoop.ipc.RemoteException: Server IPC version 7 cannot
> > communicate with client version 4"
> >
> > I know you suggested removing the 1.x jar.  I tried putting the cloudera
> > jar in there but no luck.  Should it have the same name?  Any advice on
> > getting this working?
>
> Unfortunately not, I'm using 0.20.X and haven't tried the newer stuffs
> - maybe Aaron or Gagan have?  Is that a hard requirement for you?
>

I am going to look at this tonight and get this figured out.  I have had a
couple of others ask me for the same capability.


>
> Thanks,
> --tim
>
> [1] -
> http://svn.apache.org/viewvc/zookeeper/trunk/conf/zoo_sample.cfg?revision=1421080&view=co
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message