incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From developm...@the10thfloor.com
Subject Re: Trouble Building 0.2
Date Fri, 12 Jul 2013 05:40:37 GMT
Hi Tim,

I'm slowing making progress.  Got the target built now correctly and now I
can start the controller and shard.

Unfortunately, I'm still now sure how this should be configured with my
zookeeper install.  I modified
/opt/apache-blur-0.2.0-incubating-SNAPSHOT/bin/../conf/zookeepers with the
zookeeper host ie. (localhost) for now.  However, the zookeeper log gives
me a config error when reading default_zoo.cfg. That makes sense as the
file does not exist.

---
INFO  20130712_05:29:48:048_UTC [main] quorum.QuorumPeerConfig: Reading
configuration from:
/opt/apache-blur-0.2.0-incubating-SNAPSHOT/bin/../conf/$
ERROR 20130712_05:29:48:048_UTC [main] quorum.QuorumPeerMain: Invalid
config, exiting abnormally
org.apache.zookeeper.server.quorum.QuorumPeerConfig$ConfigException: Error
processing /opt/apache-blur-0.2.0-incubating-SNAPSHOT/bin/../conf/defaul$
        at
org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.java:121)
        at
org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:101)
        at
org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:78)
Caused by: java.lang.IllegalArgumentException:
/opt/apache-blur-0.2.0-incubating-SNAPSHOT/bin/../conf/default_zoo.cfg
file is missing
        at
org.apache.zookeeper.server.quorum.QuorumPeerConfig.parse(QuorumPeerConfig.java:105)
        ... 2 more
---

I am able to successfully create a table on the local filesystem; however,
when trying to create a table in hdfs it appears as though it's not
compatible with Hadoop 2.0

"org.apache.hadoop.ipc.RemoteException: Server IPC version 7 cannot
communicate with client version 4"

I know you suggested removing the 1.x jar.  I tried putting the cloudera
jar in there but no luck.  Should it have the same name?  Any advice on
getting this working?

Thanks for the assistance, I really appreciate it.

slevytam


> On Thu, Jul 11, 2013 at 2:33 PM,  <development@the10thfloor.com> wrote:
>> Hi Tim,
>>
>> Unfortunately, all the documentation is incomplete.
>
> This is true, sorry about that, your questions help immensely in this
> area though:)
>
>> For example, the "Download Blur from here" link on the page you
>> referenced
>> goes to a page that doesn't exist.
>
> Yeah, that's probably anticipating a release - which we hope to have soon.
>
>> I was trying to follow the instructions on
>> http://wiki.apache.org/blur/QuickStart-0.2.dev; however, those are also
>> inaccurate.
>>
>> 1. git checkout 0.2-dev gives you error: pathspec '0.2-dev' did not
>> match
>> any file(s) known to git.  -> i used master instead as instructed by
>> Aaron.
>
> Yep, master is best.
>
>> 2. cd incubator-blur/src is a path that does not exist after git clone.
>> -> i used 'cd incubator-blur'
>
> that's correct, we recently flattened the project's directory
> structure to not have the extra 'src' directory, so that documentation
> is out of date.
>
>> 3. a file
>> incubator-blur/src/distribution/target/apache-blur-0.2.0-SNAPSHOT-bin.tar.gz
>> is supposed to be created in the target folder after mvn install.  this
>> does not occur.
>
> mvn install -P distribution
> .. should create artifacts in:
> incubator-blur/distribution/target/
>
>> Using find I located the files after mvn install in
>> /opt/incubator-blur/distribution/src/main/scripts/bin/.  If this is
>> wrong
>> please let me know.
>
> yeah, that's wrong, you really need the artifact itself in the
> incubator-blur/distribution/target directory.
>
> Thanks,
> --tim
>


Mime
View raw message