incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron McCurry <amccu...@gmail.com>
Subject Re: Trouble Building 0.2
Date Thu, 11 Jul 2013 01:28:36 GMT
Looks like the bind port for tests is failing. There must be another process already bound
on that port on your machine.  We should change that address to be random in the test.  I
will try to take look at it tomorrow. In the meantime if you want to run blur yes you should
disable the tests. 

Aaron

Sent from my iPad

On Jul 10, 2013, at 12:37 PM, development@the10thfloor.com wrote:

> Unfortunately, I get the same error with the master branch.  I've pasted
> my install log here: http://pastebin.com/gfzYxvr0
> 
> Should I be using -DskipTests on the mvn install command?
> 
> Thanks,
> 
> slevytam
> 
> 
> 
>> Yes, that branch is a work in progress.  Please try the master branch for
>> trying out 0.2.  Once that branch is working it will be merge into master.
>> 
>> Aaron
>> 
>> 
>> On Wed, Jul 10, 2013 at 1:52 AM, <development@the10thfloor.com> wrote:
>> 
>>> Hello,
>>> 
>>> I'm trying to give Blur a look but I am having trouble building from git
>>> checkout 0.2.0-newtypesystem.
>>> 
>>> I've attached the maven install log below.  It appears that there is
>>> some
>>> "address already in use" issue with zookeeper.
>>> 
>>> Any help would be appreciated.
>>> 
>>> Thanks,
>>> 
>>> slevytam
>>> 
>>> -----------------------------------------
>>> 
>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: Server
>>> environment:user.name=root
>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: Server
>>> environment:user.home=/root
>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: Server
>>> environment:user.dir=/opt/incubator-blur/blur-util
>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: tickTime set to 2000
>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: minSessionTimeout set to
>>> -1
>>> 13/07/10 05:43:43 INFO server.ZooKeeperServer: maxSessionTimeout set to
>>> -1
>>> 13/07/10 05:43:43 INFO server.NIOServerCnxnFactory: binding to port
>>> 0.0.0.0/0.0.0.0:10101
>>> 13/07/10 05:43:43 ERROR server.ZooKeeperServerMain: Unexpected
>>> exception,
>>> exiting abnormally
>>> java.net.BindException: Address already in use
>>>        at sun.nio.ch.Net.bind(Native Method)
>>>        at
>>> sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:137)
>>>        at
>>> sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77)
>>>        at
>>> sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:70)
>>>        at
>>> 
>>> org.apache.zookeeper.server.NIOServerCnxnFactory.configure(NIOServerCnxnFactory.java:95)
>>>        at
>>> 
>>> org.apache.zookeeper.server.ZooKeeperServerMain.runFromConfig(ZooKeeperServerMain.java:110)
>>>        at
>>> 
>>> org.apache.zookeeper.server.ZooKeeperServerMain.initializeAndRun(ZooKeeperServerMain.java:86)
>>>        at
>>> 
>>> org.apache.zookeeper.server.ZooKeeperServerMain.main(ZooKeeperServerMain.java:52)
>>>        at
>>> 
>>> org.apache.zookeeper.server.quorum.QuorumPeerMain.initializeAndRun(QuorumPeerMain.java:116)
>>>        at
>>> 
>>> org.apache.zookeeper.server.quorum.QuorumPeerMain.main(QuorumPeerMain.java:78)
>>>        at
>>> org.apache.blur.zookeeper.ZkUtilsTest$1.run(ZkUtilsTest.java:51)
>>>        at java.lang.Thread.run(Thread.java:679)
>>> 
>>> Results :
>>> 
>>> Tests run: 0, Failures: 0, Errors: 0, Skipped: 0
>>> 
>>> [INFO]
>>> ------------------------------------------------------------------------
>>> [INFO] Reactor Summary:
>>> [INFO]
>>> [INFO] Blur .............................................. SUCCESS
>>> [1.143s]
>>> [INFO] Blur Util ......................................... FAILURE
>>> [1.029s]
>>> 
>> 

Mime
View raw message