incubator-blur-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Aaron McCurry (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BLUR-103) Thrift Version incompatible with other projects
Date Thu, 23 May 2013 17:01:22 GMT

    [ https://issues.apache.org/jira/browse/BLUR-103?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13665354#comment-13665354
] 

Aaron McCurry commented on BLUR-103:
------------------------------------

I think this issue will occur across many projects.  A possible solution could to repackage
the thrift code in blur-thrift project.  That will isolate the thrift version in Blur from
other Thrift versions.  What do others think?
                
> Thrift Version incompatible with other projects
> -----------------------------------------------
>
>                 Key: BLUR-103
>                 URL: https://issues.apache.org/jira/browse/BLUR-103
>             Project: Apache Blur
>          Issue Type: Bug
>    Affects Versions: 0.1.5
>            Reporter: Joe Ferner
>
> I'm trying to get Blur to play nicely in our environment which happens to include Accumulo
1.4.3 which has a dependency on Thrift 0.6.1. Blur currently is dependent on Thrift 0.9. If
I force the Thrift version  to 0.9 Accumulo breaks, if I change the version to 0.6.1 Blur
breaks.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message