incubator-bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olemis Lang <ole...@gmail.com>
Subject Re: [Apache Bloodhound] #422: Upgrade Bootstrap to 2.3.1
Date Sun, 03 Mar 2013 09:25:47 GMT
On 3/2/13, Ryan Ollos <ryan.ollos@wandisco.com> wrote:
> On Sat, Mar 2, 2013 at 12:55 AM, Olemis Lang <olemis@gmail.com> wrote:
>
>> On 3/1/13, Apache Bloodhound <bloodhound-dev@incubator.apache.org> wrote:
>> > #422: Upgrade Bootstrap to 2.3.1
>> >
>> [...]
>> >
>> > Comment (by rjollos):
>> >
>> >  (In [1451827])
>> >
>> >  Refs #422: Updated release notes.
>> >
>>
>> Shall we upgrade to jQuery 1.9 too ? Is it required to make Bootstrap
>> 2.3.1 work ? If so how well will it play with Trac and BH specific js
>> ?
>>
>> ... or maybe that does not matter at all ?
>
>
> I didn't think about this, but it does seem like something we should have
> looked at before the upgrade to 2.3.0.
>
> Here is what I'm seeing:
>  - Trac 1.0.0 and 1.0.1 provide jQuery 1.7.2
>  - The version of jQuery provided by Trac is what we are using on all
> Bloodhound pages.
>  - Trac 1.1.x release line currently provides 1.8.3 and will eventually
> upgrade to jQuery 1.9 or 2.0 (1)
>  - Bootstrap 2.2.0 release (2) notes state "upgraded to jQuery 1.8.1"
>  - Bootstrap 2.3.0 release notes state "upgraded to jQuery 1.9"
>

AFAICR once upon a time I submitted a patch (committed afaicr) to
upgrade to jQuery 1.8.x . I guessed Trac did a similar thing later and
we just discarded our own patch . I don't recall whether at that time
some things stopped working ... but I did included it in the patch .

> Should it work with jQuery 1.7.x? How
> about 1.8.x?
>

for instance , afaicr latest versions of bootstrap were written
considering AMD and other stuff addded in 1.8.x series ... IOW some
incompatible changes might break few things

> I suppose that, whether it matters or not depends on whether anything is
> broken in Bloodhound, or could break.

I'd rather say that if there's something in Bootstrap requiring 1.9.x
then upgrading is a MUST so, before spending some time figuring this
out we better ask authors or somebody who knows , then check .

> We can use the `jquery_location`

+1

-- 
Regards,

Olemis.

Apacheā„¢ Bloodhound contributor
http://issues.apache.org/bloodhound

Blog ES: http://simelo-es.blogspot.com/
Blog EN: http://simelo-en.blogspot.com/

Featured article:

Mime
View raw message