incubator-bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrej Golcov <and...@digiverse.si>
Subject Re: [VOTE] Release Apache Bloodhound 0.4 (incubating)
Date Wed, 16 Jan 2013 15:48:03 GMT
+1 for release (non-binding)

No problems on my Mac and Windows test environments.

A few comments regarding installation process:
 - Since tar.gz format is not supported by default on Windows, I
suggest Bloodhound packaged also as zip to be become more friendly to
Windows environment. For example, Apache HTTP Server and Apache Solr
have also zip packaging.

 - Installation process, described in
https://issues.apache.org/bloodhound/wiki/BloodhoundInstall, uses svn
trunk as installation source:  "svn co
https://svn.apache.org/repos/asf/incubator/bloodhound/trunk
bloodhound"
May be it is better to start from *.tar.gz file for user installation
and use svn-based installation for BloodhoundContributing process?

 - requirements-dev.txt is used for pip install command. Should
requirements.txt be used instead?

 - windows specific activation command is not correct. Current:
"bloodhound\bin\activate.bat", must be (I guess)
"bloodhound\Scripts\activate.bat"
May be it worse to provide Windows specific installation steps or even cmd file?

Regards, Andrej

Mime
View raw message