incubator-bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Koželj <pe...@digiverse.si>
Subject Re: Genshi XHTML + HTML 5
Date Mon, 26 Nov 2012 07:03:45 GMT
The other thread "Inline editing of objects" (for the Ticket page) suggest
fallback mechanism for javascript disabled browsers.
Although this is not directly linked I would rather "advertise" BH as HTML5
UI experience than a no-javascript capable one.

Is anybody aware of any browser that is actually incapable of displaying
HTML5 page?

Peter

On 25 November 2012 20:07, Matevz Bradac <matevzb@gmail.com> wrote:

> Hi,
>
> I've started working on #217 - "Make Bloodhound's layout responsive",
> based on Joe's html mockup of the ticket page (#240).
> I noticed that the HTML output contains a mix of HTML 5 along with
> XHTML 1.0, even though the doctype is XHTML 1.0 strict.
> As a consequence (some of) the pages don't validate (e.g.
>
> http://validator.w3.org/check?uri=https://issues.apache.org/bloodhound/ticket/240
> ),
> and this may be the cause of browsers (mis)behaving and rendering
> things differently.
>
> Is there any general consensus which doctype BH should use? Since
> we're using Bootstrap I suppose it would be better to go along
> with HTML 5, but I'm not sure how this affects the templating system.
> There's a Genshi extension which could be used
> (http://code.google.com/p/genshihtml5),
> does anyone have any experience with that?
>
> Cheers,
> matevz
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message