incubator-bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Olemis Lang <ole...@gmail.com>
Subject Re: widget macros (ticket #138)
Date Fri, 30 Nov 2012 00:45:07 GMT
On 11/29/12, Gary Martin <gary.martin@wandisco.com> wrote:
> On 29/11/12 22:16, Joe Dreimann wrote:
>> On 29 Nov 2012, at 16:27, Gary Martin <gary.martin@wandisco.com> wrote:
>>
>>> On 29/11/12 15:16, Olemis Lang wrote:
>>>> On 11/29/12, Gary Martin <gary.martin@wandisco.com> wrote:
>>>>> On 19/11/12 15:36, Olemis Lang wrote:
>
[...]
>
>>>>> At some point, once we get feature parity, we could consider
>>>>> overriding
>>>>> TicketQuery so that it uses Widget(TicketQuery,...) instead.
>>>> fwiw it's possible to have TicketQueryWidget( ... ) rather than
>>>> Widget(TicketQuery, ...) . In general , <WidgetName>Widget( ... ) vs
>>>> Widget(<WidgetName>, ...)
>>> Well, not quite what I mean - two macros for effectively the same thing
>>> is not really ideal.
>
> Actually, on the subject of names, I don't see the specific requirement
> for having Widget in the name at all. Surely that doesn't strictly have
> to be the way that you distinguish that the macro is widget enhanced.
>

/me neither . Nonetheless it's a practical approach to

1. do not clash with other macro names contributed
    by core + plugins
2. provide a generic widget-to-macro mapping when
    implementing `trac.wiki.api.IWikiMacroProvider.get_macros`

;)

-- 
Regards,

Olemis.

Blog ES: http://simelo-es.blogspot.com/
Blog EN: http://simelo-en.blogspot.com/

Featured article:

Mime
View raw message