incubator-bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Martin <gary.mar...@wandisco.com>
Subject Re: [Apache Bloodhound] #154: Installer fails when providing repository type without a path and vice versa
Date Mon, 01 Oct 2012 11:30:40 GMT
On 01/10/12 11:50, Apache Bloodhound wrote:
> #154: Installer fails when providing repository type without a path and vice
> versa
> ------------------------+-----------------------
>    Reporter:  gjm        |      Owner:  jure
>        Type:  defect     |     Status:  assigned
>    Priority:  major      |  Milestone:  Release 2
>   Component:  installer  |    Version:
> Resolution:             |   Keywords:  starter
> ------------------------+-----------------------
>
> Comment (by jure):
>
>   Looking at the trac.do_initenv, the method expects both, repository type
>   and directory, to be passed. There are 2 options, we can either:
>   - require that both (type & path) are specified
>   - provide meaningful defaults for type, not sure what that would be
>   I would go with the first option, require the user to specify both and
>   fail if either is missing. Otherwise the setup output is not really what
>   user expected as the warning can easily be overlooked ...
>

I am happy with the first option for relative simplicity. So the user 
must either specify both of --repository-type and --repository-path or 
neither.

Cheers,
     Gary


Mime
View raw message