incubator-bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@wandisco.com>
Subject Re: OSX installation (Was: Re: [ANNOUNCE] Apache Bloodhound 0.1.0 incubating Released)
Date Wed, 19 Sep 2012 15:05:15 GMT
It is perfectly valid to require Xcode command-line tools for people
who're building from source. An installable binary package will not
depend on anything else, but that's off-topic for this project.

I'll take another example from Subversion which has a number of
requirements for people who build from SVN, a smaller set of
requirements for people who build from tarballs (e.g., the latter do not
need autoconf). So it's worth investigating if it's possible to build
the release tarball such that OSX users don't need Xcode; but I wouldn't
waste too much time doing that.

-- Brane


On 19.09.2012 16:32, Gary Martin wrote:
> Virtualenv is not a hard requirement but is convenient. I believe that
> we already have instructions that point out that activating a
> virtualenv is optional. I think we will just have to present this
> information to OSX users to allow them to make their own choice.
>
> If we can avoid wasting time in creating a full installer, this would
> be a very good thing. I believe that we are doing enough by providing
> appropriate instructions for successful installation and good basic
> initial configuration.
>
> Cheers,
>     Gary
>
>
> On 09/19/2012 03:03 PM, John Chambers wrote:
>> If using virtualenv is a hard requirement for the basic running of
>> Bloodhound then we just need to document, that on OSX we have a
>> dependancy
>> on the xcode command line tools. Unless we can find a way around
>> this. I am
>> neither an expert on OSX or python (yet).
>>
>> As for the wide issue of providing installer packages I agree with
>> Ian that
>> these are normally provided outside of the main project along with
>> providing support and other ancillary services. But we still need to
>> provide the instruction to get Bloodhound up and running as quickly and
>> easily as possible, with the least impact on the users existing system.
>>
>


-- 
Certified & Supported Apache Subversion Downloads:
http://www.wandisco.com/subversion/download


Mime
View raw message