incubator-bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Branko ─îibej <br...@wandisco.com>
Subject Re: Unable to install bloodhound from svn, pip install fails
Date Wed, 22 Aug 2012 18:33:00 GMT
On 22.08.2012 19:32, Gary Martin wrote:
>
> On 08/22/2012 05:36 PM, Olemis Lang wrote:
>>    - TracPermRedirect is not hosted in PyPI
>
> Looks like it is there to me.
>
>>    - latest version of TracAccountManagerPlugin in
>>      there is 0.2.1dev-r4679 whereas latest in
>>      t-h.o_shadow repository is 2.0 > r10000 .
>>      Besides it seems to me that sdist package
>>      @ PyPI is not built correctly .
>
> Yes, I spotted that it is old and I was not recommending installing
> direct from pypi. We want much newer versions than that.
>
>> IMO we should have a small package index (in ASF repository ?) in
>> order to provide alternate download links (e.g. PyPI , Bitbucket ,
>> ...) to handle situations like this .
>
> A local ASF cheeseshop might be interesting, although I don't know
> whether it is something that would be difficult to argue for.

Given the ASF policy for releasing source, not binary packages, it's not
very likely to happen. Furthermore, ASF infrastructure is intended to
support (and, to a the extent of covering the needs of the Foundation,
host) ASF projects, not to provide a repository for third-party
software; the legal implications of which I won't even try to go into,
but I expect they're not trivial.

-- Brane

-- 
Certified & Supported Apache Subversion Downloads:
http://www.wandisco.com/subversion/download


Mime
View raw message