incubator-bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Martin <gary.mar...@wandisco.com>
Subject Re: Unable to install bloodhound from svn, pip install fails
Date Wed, 22 Aug 2012 17:32:17 GMT

On 08/22/2012 05:36 PM, Olemis Lang wrote:
>    - TracPermRedirect is not hosted in PyPI

Looks like it is there to me.

>    - latest version of TracAccountManagerPlugin in
>      there is 0.2.1dev-r4679 whereas latest in
>      t-h.o_shadow repository is 2.0 > r10000 .
>      Besides it seems to me that sdist package
>      @ PyPI is not built correctly .

Yes, I spotted that it is old and I was not recommending installing 
direct from pypi. We want much newer versions than that.

> IMO we should have a small package index (in ASF repository ?) in
> order to provide alternate download links (e.g. PyPI , Bitbucket ,
> ...) to handle situations like this .

A local ASF cheeseshop might be interesting, although I don't know 
whether it is something that would be difficult to argue for. I don't 
like the idea of vendor branching all the dependencies unless we require 
big changes that make it essential.

What I would really like is for all of the dependencies to be GPG signed 
as well, and for there to be a mechanism to check that this is the case 
during the installation.

Cheers,
     Gary

Mime
View raw message