incubator-bigtop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bruno Mahé (Commented) (JIRA) <j...@apache.org>
Subject [jira] [Commented] (BIGTOP-316) split up hadoop packages into common, hdfs, mapreduce (and yarn)
Date Tue, 10 Jan 2012 21:45:40 GMT

    [ https://issues.apache.org/jira/browse/BIGTOP-316?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13183610#comment-13183610
] 

Bruno Mahé commented on BIGTOP-316:
-----------------------------------

+0 with a preference for the former.
My main concern with the latter is indexing. For instance it is convenient to know that typing
a "yum search hadoop" will bring me all hadoop related packages, and through the naming of
the package, they will be directly related to it. With the latter, typing a "yum search hadoop"
will bring a bunch of packages, but I would have to pay a lot more attention to the results.
                
> split up hadoop packages into common, hdfs, mapreduce (and yarn)
> ----------------------------------------------------------------
>
>                 Key: BIGTOP-316
>                 URL: https://issues.apache.org/jira/browse/BIGTOP-316
>             Project: Bigtop
>          Issue Type: Bug
>          Components: General
>            Reporter: Roman Shaposhnik
>            Assignee: Roman Shaposhnik
>             Fix For: 0.3.0
>
>
> Here are the new names I would like to propose in hadoop-0.23 branch:
>  * hadoop (for hadoop-common, but since it won't be limited to just the hadoop-common
project it is hadoop)
>  * hadoop-hdfs
>  * hadoop-yarn
>  * hadoop-mapreduce
>  * hadoop-hdfs-namenode
>  * hadoop-hdfs-secondarynamenode
>  * hadoop-hdfs-datanode
>  * hadoop-yarn-resourcemanager
>  * hadoop-yarn-nodemanager
>  * hadoop-mapreduce-historyserver
>  * hadoop-libhdfs
>  * hadoop-conf-pseudo
>  * hadoop-docs
> given that they look a tad too long, an alternative would be to drop hadoop- prefix and
go with
> the shorter versions (even though technically all these projects are *sub* projects of
Hadoop):
>  * hadoop
>  * hadoop-conf-pseudo
>  * hadoop-docs
>  * hdfs
>  * yarn
>  * mapreduce
>  * hdfs-namenode
>  * hdfs-secondarynamenode
>  * hdfs-datanode
>  * yarn-resourcemanager
>  * yarn-nodemanager
>  * mapreduce-historyserver
>  * libhdfs
>  * hadoop-conf-pseudo
>  * hadoop-docs
> Please leave your opinion on which one is better in the comments section.
> P.S. Quick search over at http://pkgs.org revealed no name clashes for both
> long and short versions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message