incubator-bigtop-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roman Shaposhnik (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (BIGTOP-316) split up hadoop packages into common, hdfs, mapreduce (and yarn)
Date Wed, 11 Jan 2012 02:53:40 GMT

    [ https://issues.apache.org/jira/browse/BIGTOP-316?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13183820#comment-13183820
] 

Roman Shaposhnik commented on BIGTOP-316:
-----------------------------------------

Here's a preliminary patch for the naming convention #1. It is still not a final one, since
we're blocked on upstream HADOOP-7939 for now. However, the workarounds for HADOOP-7939 seem
to be reasonable and this patch overall will be a very useful incremental step forward.

Keep an eye on FIXME/HADOOP-7939 annotations to see what will go away once HADOOP-7939 is
fixed.

Also, this patch does NOT (yet):
  * split configuration location (multiple packages contribute to /etc/hadoop/conf)
  * split actual file locations  (multiple packages contribute to /usr/lib/hadoop)
  * make real use of /var/[log|run]/[hdfs|mapreduce] (for now they are simpy symlinks to hadoop)

Once again, all of the above is going to go away once HADOOP-7939 gets fixed. Please don't
mind it too much.
                
> split up hadoop packages into common, hdfs, mapreduce (and yarn)
> ----------------------------------------------------------------
>
>                 Key: BIGTOP-316
>                 URL: https://issues.apache.org/jira/browse/BIGTOP-316
>             Project: Bigtop
>          Issue Type: Bug
>          Components: General
>            Reporter: Roman Shaposhnik
>            Assignee: Roman Shaposhnik
>             Fix For: 0.3.0
>
>         Attachments: BIGTOP-316.patch.txt
>
>
> Here are the new names I would like to propose in hadoop-0.23 branch:
>  * hadoop (for hadoop-common, but since it won't be limited to just the hadoop-common
project it is hadoop)
>  * hadoop-hdfs
>  * hadoop-yarn
>  * hadoop-mapreduce
>  * hadoop-hdfs-namenode
>  * hadoop-hdfs-secondarynamenode
>  * hadoop-hdfs-datanode
>  * hadoop-yarn-resourcemanager
>  * hadoop-yarn-nodemanager
>  * hadoop-mapreduce-historyserver
>  * hadoop-libhdfs
>  * hadoop-conf-pseudo
>  * hadoop-docs
> given that they look a tad too long, an alternative would be to drop hadoop- prefix and
go with
> the shorter versions (even though technically all these projects are *sub* projects of
Hadoop):
>  * hadoop
>  * hadoop-conf-pseudo
>  * hadoop-docs
>  * hdfs
>  * yarn
>  * mapreduce
>  * hdfs-namenode
>  * hdfs-secondarynamenode
>  * hdfs-datanode
>  * yarn-resourcemanager
>  * yarn-nodemanager
>  * mapreduce-historyserver
>  * libhdfs
>  * hadoop-conf-pseudo
>  * hadoop-docs
> Please leave your opinion on which one is better in the comments section.
> P.S. Quick search over at http://pkgs.org revealed no name clashes for both
> long and short versions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message