incubator-bigtop-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bm...@apache.org
Subject svn commit: r1182236 - in /incubator/bigtop/trunk/bigtop-packages/src/rpm: flume/SPECS/flume.spec hadoop/SPECS/hadoop.spec hbase/SPECS/hbase.spec sqoop/SPECS/sqoop.spec zookeeper/SPECS/zookeeper.spec
Date Wed, 12 Oct 2011 07:00:18 GMT
Author: bmahe
Date: Wed Oct 12 07:00:18 2011
New Revision: 1182236

URL: http://svn.apache.org/viewvc?rev=1182236&view=rev
Log:
BIGTOP-113. Fix dependency for mageia on lsb init scripts helpers for flume, hadoop, sqoop,
zookeeper and hbase

Modified:
    incubator/bigtop/trunk/bigtop-packages/src/rpm/flume/SPECS/flume.spec
    incubator/bigtop/trunk/bigtop-packages/src/rpm/hadoop/SPECS/hadoop.spec
    incubator/bigtop/trunk/bigtop-packages/src/rpm/hbase/SPECS/hbase.spec
    incubator/bigtop/trunk/bigtop-packages/src/rpm/sqoop/SPECS/sqoop.spec
    incubator/bigtop/trunk/bigtop-packages/src/rpm/zookeeper/SPECS/zookeeper.spec

Modified: incubator/bigtop/trunk/bigtop-packages/src/rpm/flume/SPECS/flume.spec
URL: http://svn.apache.org/viewvc/incubator/bigtop/trunk/bigtop-packages/src/rpm/flume/SPECS/flume.spec?rev=1182236&r1=1182235&r2=1182236&view=diff
==============================================================================
--- incubator/bigtop/trunk/bigtop-packages/src/rpm/flume/SPECS/flume.spec (original)
+++ incubator/bigtop/trunk/bigtop-packages/src/rpm/flume/SPECS/flume.spec Wed Oct 12 07:00:18
2011
@@ -87,11 +87,19 @@ Requires(preun): /sbin/service, /sbin/ch
 %if  %{?suse_version:1}0
 # Required for init scripts
 Requires: insserv
-%else
+%endif
+
+%if  0%{?mgaversion}
 # Required for init scripts
-Requires: redhat-lsb
+Requires: initscripts
 %endif
 
+# CentOS 5 does not have any dist macro
+# So I will suppose anything that is not Mageia or a SUSE will be a RHEL/CentOS/Fedora
+%if %{!?suse_version:1}0 && %{!?mgaversion:1}0
+# Required for init scripts
+Requires: redhat-lsb
+%endif
 
 %description master
 Flume is a reliable, scalable, and manageable distributed data collection application for
collecting data such as logs and delivering it to data stores such as Hadoop's HDFS.  It can
efficiently collect, aggregate, and move large amounts of log data.  It has a simple, but
flexible, architecture based on streaming data flows.  It is robust and fault tolerant with
tunable reliability mechanisms and many failover and recovery mechanisms.  The system is centrally
managed and allows for intelligent dynamic management. It uses a simple extensible data model
that allows for online analytic applications.
@@ -108,11 +116,19 @@ Requires(preun): /sbin/service, /sbin/ch
 %if  %{?suse_version:1}0
 # Required for init scripts
 Requires: insserv
-%else
+%endif
+
+%if  0%{?mgaversion}
 # Required for init scripts
-Requires: redhat-lsb
+Requires: initscripts
 %endif
 
+# CentOS 5 does not have any dist macro
+# So I will suppose anything that is not Mageia or a SUSE will be a RHEL/CentOS/Fedora
+%if %{!?suse_version:1}0 && %{!?mgaversion:1}0
+# Required for init scripts
+Requires: redhat-lsb
+%endif
 
 %description node
 Flume is a reliable, scalable, and manageable distributed data collection application for
collecting data such as logs and delivering it to data stores such as Hadoop's HDFS.  It can
efficiently collect, aggregate, and move large amounts of log data.  It has a simple, but
flexible, architecture based on streaming data flows.  It is robust and fault tolerant with
tunable reliability mechanisms and many failover and recovery mechanisms.  The system is centrally
managed and allows for intelligent dynamic management. It uses a simple extensible data model
that allows for online analytic applications.

Modified: incubator/bigtop/trunk/bigtop-packages/src/rpm/hadoop/SPECS/hadoop.spec
URL: http://svn.apache.org/viewvc/incubator/bigtop/trunk/bigtop-packages/src/rpm/hadoop/SPECS/hadoop.spec?rev=1182236&r1=1182235&r2=1182236&view=diff
==============================================================================
--- incubator/bigtop/trunk/bigtop-packages/src/rpm/hadoop/SPECS/hadoop.spec (original)
+++ incubator/bigtop/trunk/bigtop-packages/src/rpm/hadoop/SPECS/hadoop.spec Wed Oct 12 07:00:18
2011
@@ -128,7 +128,7 @@ Requires: sh-utils, redhat-lsb
 
 %if  0%{?mgaversion}
 BuildRequires: libfuse-devel, libfuse2 , libopenssl-devel, gcc-c++, ant, libtool, automake,
autoconf, liblzo-devel, zlib-devel
-Requires: chkconfig, xinetd-simple-services, zlib
+Requires: chkconfig, xinetd-simple-services, zlib, initscripts
 %endif
 
 

Modified: incubator/bigtop/trunk/bigtop-packages/src/rpm/hbase/SPECS/hbase.spec
URL: http://svn.apache.org/viewvc/incubator/bigtop/trunk/bigtop-packages/src/rpm/hbase/SPECS/hbase.spec?rev=1182236&r1=1182235&r2=1182236&view=diff
==============================================================================
--- incubator/bigtop/trunk/bigtop-packages/src/rpm/hbase/SPECS/hbase.spec (original)
+++ incubator/bigtop/trunk/bigtop-packages/src/rpm/hbase/SPECS/hbase.spec Wed Oct 12 07:00:18
2011
@@ -97,11 +97,19 @@ Requires: %{name} = %{version}-%{release
 %if  %{?suse_version:1}0
 # Required for init scripts
 Requires: insserv
-%else
+%endif
+
+%if  0%{?mgaversion}
 # Required for init scripts
-Requires: redhat-lsb
+Requires: initscripts
 %endif
 
+# CentOS 5 does not have any dist macro
+# So I will suppose anything that is not Mageia or a SUSE will be a RHEL/CentOS/Fedora
+%if %{!?suse_version:1}0 && %{!?mgaversion:1}0
+# Required for init scripts
+Requires: redhat-lsb
+%endif
 
 %description master
 HMaster is the "master server" for a HBase. There is only one HMaster for a single HBase
deployment.
@@ -115,7 +123,16 @@ Requires: %{name} = %{version}-%{release
 %if  %{?suse_version:1}0
 # Required for init scripts
 Requires: insserv
-%else
+%endif
+
+%if  0%{?mgaversion}
+# Required for init scripts
+Requires: initscripts
+%endif
+
+# CentOS 5 does not have any dist macro
+# So I will suppose anything that is not Mageia or a SUSE will be a RHEL/CentOS/Fedora
+%if %{!?suse_version:1}0 && %{!?mgaversion:1}0
 # Required for init scripts
 Requires: redhat-lsb
 %endif
@@ -133,7 +150,16 @@ Requires: %{name} = %{version}-%{release
 %if  %{?suse_version:1}0
 # Required for init scripts
 Requires: insserv
-%else
+%endif
+
+%if  0%{?mgaversion}
+# Required for init scripts
+Requires: initscripts
+%endif
+
+# CentOS 5 does not have any dist macro
+# So I will suppose anything that is not Mageia or a SUSE will be a RHEL/CentOS/Fedora
+%if %{!?suse_version:1}0 && %{!?mgaversion:1}0
 # Required for init scripts
 Requires: redhat-lsb
 %endif

Modified: incubator/bigtop/trunk/bigtop-packages/src/rpm/sqoop/SPECS/sqoop.spec
URL: http://svn.apache.org/viewvc/incubator/bigtop/trunk/bigtop-packages/src/rpm/sqoop/SPECS/sqoop.spec?rev=1182236&r1=1182235&r2=1182236&view=diff
==============================================================================
--- incubator/bigtop/trunk/bigtop-packages/src/rpm/sqoop/SPECS/sqoop.spec (original)
+++ incubator/bigtop/trunk/bigtop-packages/src/rpm/sqoop/SPECS/sqoop.spec Wed Oct 12 07:00:18
2011
@@ -57,7 +57,16 @@ Requires: sqoop = %{version}-%{release} 
 %if  %{?suse_version:1}0
 # Required for init scripts
 Requires: insserv
-%else
+%endif
+
+%if  0%{?mgaversion}
+# Required for init scripts
+Requires: initscripts
+%endif
+
+# CentOS 5 does not have any dist macro
+# So I will suppose anything that is not Mageia or a SUSE will be a RHEL/CentOS/Fedora
+%if %{!?suse_version:1}0 && %{!?mgaversion:1}0
 # Required for init scripts
 Requires: redhat-lsb
 %endif

Modified: incubator/bigtop/trunk/bigtop-packages/src/rpm/zookeeper/SPECS/zookeeper.spec
URL: http://svn.apache.org/viewvc/incubator/bigtop/trunk/bigtop-packages/src/rpm/zookeeper/SPECS/zookeeper.spec?rev=1182236&r1=1182235&r2=1182236&view=diff
==============================================================================
--- incubator/bigtop/trunk/bigtop-packages/src/rpm/zookeeper/SPECS/zookeeper.spec (original)
+++ incubator/bigtop/trunk/bigtop-packages/src/rpm/zookeeper/SPECS/zookeeper.spec Wed Oct
12 07:00:18 2011
@@ -98,11 +98,21 @@ BuildArch: noarch
 %if  %{?suse_version:1}0
 # Required for init scripts
 Requires: insserv
-%else
+%endif
+
+%if  0%{?mgaversion}
+# Required for init scripts
+Requires: initscripts
+%endif
+
+# CentOS 5 does not have any dist macro
+# So I will suppose anything that is not Mageia or a SUSE will be a RHEL/CentOS/Fedora
+%if %{!?suse_version:1}0 && %{!?mgaversion:1}0
 # Required for init scripts
 Requires: redhat-lsb
 %endif
 
+
 %description server
 This package starts the zookeeper server on startup
 



Mime
View raw message