incubator-any23-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lewis John Mcgibbney <lewis.mcgibb...@gmail.com>
Subject Issues with build
Date Tue, 08 May 2012 18:13:08 GMT
Hi Guys,

I've been off the beaten track for a week or so and haven't had much
time to put towards Any23.

I'm getting some pretty horrible build output when checking out trunk
and doing mvn clean install.

Failed tests:
testSpeciesMicroformatExtractOverTaxoBox(org.apache.any23.extractor.html.SpeciesExtractorTest):
Unexpected number of matching statements. expected:<29> but was:<27>
  testListingWithouthContent(org.apache.any23.extractor.html.HListingExtractorTest):
Unexpected number of matching statements. expected:<4> but was:<3>
  testVCardMultiAddress(org.apache.any23.extractor.html.AdrExtractorTest):
Unexpected statement size: 5
  testAdvancedItemrefManagement(org.apache.any23.extractor.microdata.MicrodataParserTest):
Error while comparing error [1] expected:<...[2]", "begin_row" : [10,
"begin_col" : 5, "end_row" : 10], "end_col" : 97 }> but was:<...[2]",
"begin_row" : [26, "begin_col" : 5, "end_row" : 26], "end_col" : 97 }>
  testMicroformatDomains(org.apache.any23.extractor.SingleDocumentExtractionTest):
Cannot find triple (* http://vocab.sindice.net/any23#domain
"nested.test.com") 1 times expected:<1> but was:<0>
  testNestedMicroformats(org.apache.any23.extractor.SingleDocumentExtractionTest):
Cannot find triple (* http://vocab.sindice.net/any23#domain
"nested.test.com") 2 times expected:<2> but was:<0>
  testNestedMicroformatsInduced(org.apache.any23.extractor.SingleDocumentExtractionTest):
Cannot find triple (* http://vocab.sindice.net/any23#domain
"nested.test.com") 2 times expected:<2> but was:<0>
  testNestedMicroformatsManaged(org.apache.any23.extractor.SingleDocumentExtractionTest):
Cannot find triple (* http://vocab.sindice.net/any23#domain
"nested.test.com") 3 times expected:<3> but was:<0>
  testDetectRSS1ByContent(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error in mimetype detection for file
/home/lewis/ASF/any23/core/src/test/resources/application/rss1/test1
expected:<application/[rdf+xml]> but was:<application/[octet-stream]>
  testDetectRDFN3ByContent(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error in mimetype detection for file
/home/lewis/ASF/any23/core/src/test/resources/application/rdfn3/test1
expected:<[text/n3]> but was:<[application/octet-stream]>
  testDetectRDFNQuadsByContent(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error in mimetype detection for file
/home/lewis/ASF/any23/core/src/test/resources/application/nquads/test1.nq
expected:<[text/nq]> but was:<[application/octet-stream]>
  testDetectRDFXMLByContent(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error in mimetype detection for file
/home/lewis/ASF/any23/core/src/test/resources/application/rdfxml/test1
expected:<application/[rdf+xml]> but was:<application/[octet-stream]>
  testDetectHTMLByContent(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error in mimetype detection for file
/home/lewis/ASF/any23/core/src/test/resources/text/html/test1
expected:<[text/html]> but was:<[application/octet-stream]>
  testRDFXMLByContentAndName(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error while detecting mimetype in file
src/test/resources/application/rdfxml/test1
expected:<application/[rdf+xml]> but was:<application/[octet-stream]>
  testRSS1ByContentAndName(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error while detecting mimetype in file
src/test/resources/application/rss1/test1
expected:<application/[rdf+xml]> but was:<application/[octet-stream]>
  testDetectRDFN3ByContentAndName(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error while detecting mimetype in file
src/test/resources/application/rdfn3/test1 expected:<[text/n3]> but
was:<[application/octet-stream]>
  testHTMLByContentAndName(org.apache.any23.mime.TikaMIMETypeDetectorTest):
Error while detecting mimetype in file
src/test/resources/text/html/test1 expected:<[text/html]> but
was:<[application/octet-stream]>

Tests run: 399, Failures: 17, Errors: 0, Skipped: 1

When I last tried... some 2 weeks or so ago, I was getting one failed
test (this is reflected by the nightly build output... when it
actually runs the tests), now it seems to have snowballed quite a bit
and my situation locally is pretty dim.

Can anyone reproduce this behaviour?
Thank you

Lewis

-- 
Lewis

Mime
View raw message