incubator-any23-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lewis John Mcgibbney <lewis.mcgibb...@gmail.com>
Subject Re: [DISCUSSION] 0.7.0 Release
Date Fri, 17 Feb 2012 15:00:02 GMT
Hi Andy,

I'm kinda loosing the track with this one. Working on this comment

On Thu, Feb 16, 2012 at 10:57 PM, Andy Seaborne <andy@apache.org> wrote:

>
> It seems to be used by edu.uci.ics.crawler4j v2.6.1
>
> I see on maven central there is a v3.0/3.1 (no 2.6.1).
> 3.1 does not have a declared dsiutils dependency - maybe it does not need
> it now.
>
>
> I've patched any23 to nearly work with Crawler4j 3.3. I get one compile
error but I think submitting the patch now under ANY23-27 is the best thing
as it gives us an opportunity to strike whilst the iron is hot. So please
see the patch on the issue.

As I've not been able to get this to compile yet, I can't declare whether
we can completely drop the offending LGPL library.
One thing which I think it worth noting, is that when I contacted
Sebastiano yday he mentioned
{qt}
My guess is Bloom filters. You can reimplement them in a day, or substitute
then with a LongOpenHashSet of 64-bit signatures.
{qt}
Is this possibly why we rely upon DSIutils?

Anyway, hopefully the former comes to fruition  and crawler4j doesn't need
to rely upon DSIutils anymore... (ahem).
Here's to hoping :0)

Lewis

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message