incubator-amber-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pid <...@pidster.com>
Subject Re: Preparing code for the first release
Date Tue, 19 Jul 2011 09:36:56 GMT
On 18/07/2011 16:48, Raymond Feng wrote:
> It's project by project. The only requirement is to have -incubating as part of the version.
> 
> In Amber case, if we reserve version 1.0 to match the final oAuth 2.0 spec, we can start
with 0.x-incubating, even 0.5-incubating.

That's a sensible suggestion.


p

> We should try to use maven release plugin to handle the maven release.
> 
> Thanks,
> Raymond
> ________________________________________________________________ 
> Raymond Feng
> rfeng@apache.org
> Apache Tuscany PMC member and committer: tuscany.apache.org
> Co-author of Tuscany SCA In Action book: www.tuscanyinaction.com
> Personal Web Site: www.enjoyjava.com
> ________________________________________________________________
> 
> On Jul 18, 2011, at 6:15 AM, Pid wrote:
> 
>> On 18/07/2011 12:13, Łukasz Moreń wrote:
>>> Yes, a 1.0 release.
>>
>> I think we should aim lower & start with a 0.1.
>>
>> This will give us the chance to work towards a declaration that an
>> eventual 1.0 is stable and bug-free.  We need to be public and get user
>> feedback to achieve that IMHO.
>>
>> I think most incubator projects start with a 0.1 but that's probably
>> convention.
>>
>> Thoughts?
>>
>>
>> p
>>
>>
>>
>>> On Mon, Jul 18, 2011 at 12:07 PM, Pid <pid@pidster.com> wrote:
>>>
>>>> On 18/07/2011 11:52, Maciej Machulak wrote:
>>>>> Hi all,
>>>>>
>>>>> On 18 July 2011 10:34, Łukasz Moreń <lukasz.moren@gmail.com>
wrote:
>>>>>> Hi all,
>>>>>>
>>>>>> I think there are some things that need to be improved before the
>>>> release.
>>>>>> Could you please suggest what Amber is currently missing what is
>>>> required
>>>>>> for the release or ideally try to fix it :)?.
>>>>>
>>>>> Yes, this would be great. We'll then use the feedback and improve
>>>>> what's necessary.
>>>>>
>>>>>> With Maciej we will work on OAuth 2.0 module. From what I see should
be
>>>>>> done:
>>>>>>
>>>>>> - unify maven dependencies in oauth 2.0 module by specifying versions
in
>>>>>> <dependencyManagement> in the main pom
>>>>>
>>>>> Fully agree.
>>>>>
>>>>>> - change oauth 2.0 module version form 0.2-SNAPSHOT to 1.0-SNAPSHOT
>>>> (used by
>>>>>> the core pom) - is this change safe?
>>>>>
>>>>> Ah, yes. This should be probably changed.
>>>>>
>>>>> Anyway, lets look for some feedback and then we'll make the changes.
>>>>> It'll be great if somebody more experienced could help with the Apache
>>>>> process (ip, voting, etc.).
>>>>
>>>> Do you mean that we'd be preparing a 1.0 release?  Or are you referring
>>>> to something else?
>>>>
>>>>
>>>> p
>>>>
>>>>
>>>>>> Cheers,
>>>>>> Lukasz Moren
>>>>>>
>>>>>
>>>>> Cheers,
>>>>> Maciej
>>>>>
>>>>
>>>>
>>>>
>>>
>>
>>
> 
> 



Mime
View raw message