incubator-amber-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From simonetrip...@apache.org
Subject svn commit: r1230040 - /incubator/amber/trunk/pom.xml
Date Wed, 11 Jan 2012 13:55:20 GMT
Author: simonetripodi
Date: Wed Jan 11 13:55:20 2012
New Revision: 1230040

URL: http://svn.apache.org/viewvc?rev=1230040&view=rev
Log:
updated maven-enforcer-plugin

Modified:
    incubator/amber/trunk/pom.xml

Modified: incubator/amber/trunk/pom.xml
URL: http://svn.apache.org/viewvc/incubator/amber/trunk/pom.xml?rev=1230040&r1=1230039&r2=1230040&view=diff
==============================================================================
--- incubator/amber/trunk/pom.xml (original)
+++ incubator/amber/trunk/pom.xml Wed Jan 11 13:55:20 2012
@@ -333,6 +333,40 @@
 
     <plugins>
       <plugin>
+        <groupId>org.apache.maven.plugins</groupId>
+        <artifactId>maven-enforcer-plugin</artifactId>
+        <version>1.0</version>
+        <executions>
+          <execution>
+            <id>enforce-java</id>
+            <phase>validate</phase>
+            <goals>
+              <goal>enforce</goal>
+            </goals>
+            <configuration>
+              <rules>
+                <requireJavaVersion>
+                  <version>[1.6,)</version>
+                  <message>[ERROR] The currently supported version of Java is 1.6 or
higher</message>
+                </requireJavaVersion>
+                <requireMavenVersion>
+                  <version>[2.2.0,)</version>
+                  <message>[ERROR] The currently supported version of Maven is 2.2.0
or higher</message>
+                </requireMavenVersion>
+                <requirePluginVersions>
+                  <message>Best Practice is to always define plugin versions!</message>
+                  <banLatest>true</banLatest>
+                  <banRelease>true</banRelease>
+                  <banSnapshots>true</banSnapshots>
+                  <phases>[ERROR] clean,deploy,site</phases>
+                </requirePluginVersions>
+              </rules>
+            </configuration>
+          </execution>
+        </executions>
+      </plugin>
+
+      <plugin>
         <groupId>org.codehaus.mojo</groupId>
         <artifactId>buildnumber-maven-plugin</artifactId>
         <version>1.0</version>
@@ -420,38 +454,6 @@
 
       <plugin>
         <groupId>org.apache.maven.plugins</groupId>
-        <artifactId>maven-enforcer-plugin</artifactId>
-        <version>1.0-beta-1</version>
-        <executions>
-          <execution>
-            <id>enforce-java</id>
-            <phase>validate</phase>
-            <goals>
-              <goal>enforce</goal>
-            </goals>
-            <configuration>
-              <rules>
-                <requireJavaVersion>
-                  <version>[1.6,)</version>
-                </requireJavaVersion>
-                <requireMavenVersion>
-                  <version>[2.2.0,)</version>
-                </requireMavenVersion>
-                <requirePluginVersions>
-                  <message>Best Practice is to always define plugin versions!</message>
-                  <banLatest>true</banLatest>
-                  <banRelease>true</banRelease>
-                  <banSnapshots>true</banSnapshots>
-                  <phases>clean,deploy,site</phases>
-                </requirePluginVersions>
-              </rules>
-            </configuration>
-          </execution>
-        </executions>
-      </plugin>
-
-      <plugin>
-        <groupId>org.apache.maven.plugins</groupId>
         <artifactId>maven-compiler-plugin</artifactId>
         <version>2.3.2</version>
         <configuration>



Mime
View raw message