incubator-ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yusaku Sako <yus...@hortonworks.com>
Subject Re: Local repositories not being used
Date Thu, 01 Aug 2013 04:53:43 GMT
Glad I was able to help!
BTW, there's some work going on to enhance local repo setup user experience
to avoid running into an issue like this in the first place.
Currently there's a disconnect between manually editing the "local" version
of the stack to specify the repo URLs and then remembering to check the
local repo checkbox in the UI.  Also, if you make typos in the repo URLs,
you won't find out until much later when you deploy (which is a pain).
In the future this will all be done via the web UI with repo URL
validations, etc. (and of course REST API endpoints to do all that).

Yusaku



On Wed, Jul 31, 2013 at 9:37 PM, Christian Smith
<christian@greenbutton.com>wrote:

> That will be it, I forgot about that option...
>
> Thanks Yusaku!
>
>
> On Thu, Aug 1, 2013 at 4:32 PM, Yusaku Sako <yusaku@hortonworks.com>wrote:
>
>> Hi Christian,
>>
>> Did you click on "Use a Local Software Repository instead of downloading
>> software packages from the Internet" in the "Install Options" page of the
>> Install Wizard (the page where you specify hosts)?  That checkbox must be
>> checked if you are using a local repo.
>>
>> Yusaku
>>
>>
>> On Wed, Jul 31, 2013 at 9:10 PM, Christian Smith <
>> christian@greenbutton.com> wrote:
>>
>>> Hi,
>>>
>>> I've been using Ambari 1.2.4 and having some trouble with 'local repos'.
>>>  Everything is fine on the ambari-server and I've updated the following
>>> with my local repo:
>>>
>>> /var/lib/ambari-server/resources/stacks/HDPLocal/1.3.0/repos/repoinfo.xml
>>>
>>> The agents are installed/configured using password-less SSH, this works
>>> fine.
>>>
>>> What I've noticed is that whenever I attempt to install services via the
>>> web UI wizard, the agents receive the regular HDP-1.3.0 repo, not the
>>> HDPLocal-1.3.0 repo.
>>>
>>> So my question is, where is the repo specified for the cluster?  Is this
>>> the stack selected in the UI wizard?
>>>
>>> Any help is appreciated...
>>>
>>> Thanks,
>>> Christian
>>>
>>
>>
>

Mime
View raw message