incubator-ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Su Kucherova <su.kucher...@gmail.com>
Subject Re: Next button is disabled after successful confirm hosts in 1.2.1
Date Fri, 08 Mar 2013 06:42:29 GMT
Thanks


On Fri, Mar 8, 2013 at 11:56 AM, Yusaku Sako <yusaku@hortonworks.com> wrote:

> Hi Su,
>
> If you are hitting the same problem, please try hitting the following
> URL when you see the error in the same browser as Ambari Web:
>
> http://ambari-server:8080/api/v1/hosts?fields=Hosts/last_agent_env
>
> For all hosts, you should see JSON like the following:
>     "Hosts" : {
>         "last_agent_env" : {
>           "paths" : [
>             {
>               "name" : "/etc/hadoop",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/etc/hadoop/conf",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/etc/hbase",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/etc/hcatalog",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/etc/hive",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/etc/oozie",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/etc/sqoop",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/etc/ganglia",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/etc/nagios",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/run/hadoop",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/run/zookeeper",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/run/hbase",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/run/templeton",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/run/oozie",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/log/hadoop",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/log/zookeeper",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/log/hbase",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/run/templeton",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/log/hive",
>               "type" : "not_exist"
>             },
>             {
>               "name" : "/var/log/nagios",
>               "type" : "not_exist"
>             }
>           ],
>           "javaProcs" : [ ],
>           "rpms" : [
>             {
>               "name" : "nagios",
>               "installed" : false
>             },
>             {
>               "name" : "ganglia",
>               "installed" : false
>             },
>             {
>               "name" : "hadoop",
>               "installed" : false
>             },
>             {
>               "name" : "hbase",
>               "installed" : false
>             },
>             {
>               "name" : "oozie",
>               "installed" : false
>             },
>             {
>               "name" : "sqoop",
>               "installed" : false
>             },
>             {
>               "name" : "pig",
>               "installed" : false
>             },
>             {
>               "name" : "zookeeper",
>               "installed" : false
>             },
>             {
>               "name" : "hive",
>               "installed" : false
>             },
>             {
>               "name" : "libconfuse",
>               "installed" : false
>             },
>             {
>               "name" : "ambari-log4j",
>               "installed" : false
>             }
>           ],
>           "varRunHadoopPidCount" : 0,
>           "varLogHadoopLogCount" : 0,
>           "etcAlternativesConf" : [ ],
>           "repoInfo" : "Loaded plugins: amazon-id, product-id,
> rhui-lb, security, subscription-manager\nUpdating certificate-based
> repositories.\nrepo id                                      repo name
>                   status\nHDP-UTILS-1.1.0.15
> Hortonworks Data Platform Ut     52\nUpdates-ambari-1.x
>            ambari-1.x - Updates              5\nambari-1.x
>                       Ambari 1.x                        5\nepel
>                                  Extra Packages for Enterpris
> 8,425\nrhui-us-east-1-client-config-server-6        Red Hat Update
> Infrastructur      2\nrhui-us-east-1-rhel-server-releases          Red
> Hat Enterprise Linux Ser
> 10,138\nrhui-us-east-1-rhel-server-releases-optional Red Hat
> Enterprise Linux Ser  5,986\nrepolist: 24,613\n"
>         },
>         "host_name" : "ip-10-76-191-181.ec2.internal"
>       }
>
> If you don't see that for all hosts, your ambari-agent is not the
> correct version.
> You should also see the similar output in
> /var/log/ambari-agent/ambari-agent.log on all of your hosts.
>
> Thanks,
> Yusaku
>
>
> On Thu, Mar 7, 2013 at 10:19 PM, Su Kucherova <su.kucherova@gmail.com>
> wrote:
> > Even I am facing the same issue.
> > I upgraded all the agents to 1.2.1.2-1
> >
> >
> > On Fri, Mar 8, 2013 at 11:14 AM, Yusaku Sako <yusaku@hortonworks.com>
> wrote:
> >>
> >> Ok.  Could you file a JIRA and post the content of
> >> /var/log/ambari-agent/ambari-agent.log from all hosts, as well as
> >> /var/log/ambari-server/ambari-server.log from the Ambari Server?
> >>
> >> Thanks,
> >> Yusaku
> >>
> >> On Thu, Mar 7, 2013 at 9:27 PM, Dustine Rene Bernasor
> >> <dustine@thecyberguardian.com> wrote:
> >> > Hello,
> >> >
> >> > The version is already 1.2.1.2-1 on all hosts.
> >> >
> >> > Dustine
> >> >
> >> >
> >> >
> >> > On 3/8/2013 1:14 PM, Yusaku Sako wrote:
> >> >>
> >> >> Hi Dustine,
> >> >>
> >> >> Sorry to hear that you are having trouble.
> >> >> The error message leads me to believe that the agents were not
> >> >> upgraded.
> >> >>
> >> >> On all the hosts, you should see:
> >> >>
> >> >> # yum list ambari-agent
> >> >> ...
> >> >> ambari-agent.x86_64                1.2.1.2-1
> >> >> @Updates-ambari-1.x
> >> >>
> >> >> Is that the version you see?
> >> >> If not, you need to follow the instructions here:
> >> >>
> >> >>
> >> >>
> http://incubator.apache.org/ambari/1.2.1/installing-hadoop-using-ambari/content/ambari-chap7.html
> >> >>
> >> >> Yusaku
> >> >>
> >> >> On Thu, Mar 7, 2013 at 8:50 PM, Dustine Rene Bernasor
> >> >> <dustine@thecyberguardian.com> wrote:
> >> >>>
> >> >>> Hello again,
> >> >>>
> >> >>> I upgraded to 1.2.1 and did a reset (again), doing everything for
> >> >>> scratch.
> >> >>>
> >> >>> This time, when I reach the Confirm Hosts step, everything is
> >> >>> successful
> >> >>> but the Next button is disabled and I cannot proceed to the next
> step.
> >> >>> (screenshot attached)
> >> >>>
> >> >>> There is an error according to the Chrome dev tools:
> >> >>>
> >> >>> Uncaught TypeError: Cannot read property 'paths' of null app.js:8969
> >> >>>
> >> >>> (anonymous function)app.js:8969
> >> >>>
> >> >>>
> App.WizardStep3Controller.Em.Controller.extend.parseWarningsapp.js:8960
> >> >>> $.ajax.successapp.js:8767
> >> >>> ovendor.js:91
> >> >>> p.fireWithvendor.js:91
> >> >>> wvendor.js:93
> >> >>> d
> >> >>>
> >> >>> Thanks.
> >> >>>
> >> >>> Dustine
> >> >>>
> >> >>>
> >> >
> >
> >
>

Mime
View raw message