incubator-ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Siddharth Wagle <swa...@hortonworks.com>
Subject Re: Ambari startup issues on CentOS 6.3
Date Tue, 26 Feb 2013 20:47:26 GMT
Hi Bill,

Please take a look at /var/log/ambari-server/ambari-server.log for any
exceptions.

Also is there any service already running on 8080?

Thanks,
Sid

On Tue, Feb 26, 2013 at 12:38 PM, Bill Stephens <grapeguy@gmail.com> wrote:

> All,
>
> I am attempting to install Hortonwprks Data Platform using Ambari on a
> CentOS 6.3 server following these instructions:
> http://docs.hortonworks.com/HDPDocuments/HDP1/HDP-1.2.1/bk_using_Ambari_book/content/ambari-chap1.html
>
> I'm fine until I start the server. It appears to start correctly but dies
> about 10 seconds later with no  cause...
>
> *Ambari is installed and configured*
>
> [root@horton ~]# yum list | grep ambari
>
> ambari-server.noarch                1.2.0.1-1             @AMBARI-1.x
>
>
> ambari-agent.x86_64                 1.2.0.1-1             AMBARI-1.x
>
>
> ambari-log4j.noarch                 1.0-1                 AMBARI-1.x
>
>
> *Ambari-server setup returns with success*
>
> [root@horton ~]# ambari-server setup
>
> Using python  /usr/bin/python2.6
>
> Run postgresql initdb
>
> Run postgresql start
>
> Starting postgresql service:                               [  OK  ]
>
> Setup ambari-server
>
> Checking SELinux...
>
> SELinux status is 'disabled'
>
> Checking iptables...
>
> iptables is disabled now
>
> Checking PostgreSQL...
>
> Configuring database...
>
> Configuring PostgreSQL...
>
> Backup for pg_hba found, reconfiguration not required
>
> Checking JDK...
>
> Completing setup...
>
> Ambari Server 'setup' finished successfully
>
>
> *Starting appears to work: for about 10 seconds before  shutting down*
>
> [root@horton ~]# /usr/bin/time date
>
> Tue Feb 26 15:19:43 EST 2013
>
>
> [root@horton ~]# ambari-server start
>
> Using python  /usr/bin/python2.6
>
> Starting ambari-server
>
> Checking iptables...
>
> iptables is disabled now
>
> Running server: /usr/jdk64/jdk1.6.0_31/bin/java -server -XX:NewRatio=2
> -XX:+UseConcMarkSweepGC -Xms512m -Xmx2048m -cp
> /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/usr/lib/ambari-server/*
> org.apache.ambari.server.controller.AmbariServer
> >/var/log/ambari-server/ambari-server.out 2>&1
>
>
> [root@horton ~]# /usr/bin/time date
>
> Tue Feb 26 15:19:48 EST 2013
>
> [root@horton ~]# ambari-server start
>
> Using python  /usr/bin/python2.6
>
> Starting ambari-server
>
> Server is already running.
>
>
> [root@horton ~]# /usr/bin/time date
>
> Tue Feb 26 15:19:52 EST 2013
>
> [root@horton ~]# ambari-server start
>
> Using python  /usr/bin/python2.6
>
> Starting ambari-server
>
> Checking iptables...
>
> iptables is disabled now
>
> Running server: /usr/jdk64/jdk1.6.0_31/bin/java -server -XX:NewRatio=2
> -XX:+UseConcMarkSweepGC -Xms512m -Xmx2048m -cp
> /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/lib64/qt-3.3/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/usr/lib/ambari-server/*
> org.apache.ambari.server.controller.AmbariServer
> >/var/log/ambari-server/ambari-server.out 2>&1
>
> *The log never contains more information than this…*
>
> [root@horton ~]# more /var/log/ambari-server/ambari-server.out
>
> [EL Info]: 2013-02-26 15:19:59.045--ServerSession(605399375)--EclipseLink,
> version: Eclipse Persistence Services - 2.4.0.v20120608-r11652
>
> [EL Info]: connection: 2013-02-26
> 15:19:59.75--ServerSession(605399375)--file:/usr/lib/ambari-server/ambari-server-1.2.0.1.jar_ambari-postgres_user=ambari-server
> login successful
>
>
>
>
>
>

Mime
View raw message