incubator-ambari-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jinwei zhu <zhujinwe...@gmail.com>
Subject Re: about AMBARI-666 ambari-web not login
Date Thu, 10 Jan 2013 15:07:11 GMT
HI, Yusaku,  since ambari web ui has not worked well, I am trying to use
"httpclient" to send request by rest service , and the request is to create
a cluster.
Here is the java code :
        String restURL="http://myhostname:8080/api/clusters/mycluster"
         HttpClient client=new HttpClient();
        PostMethod postMethod = new PostMethod(restURL);
        String body="{\"hostname\":\"myhostname\"}";
        postMethod.setRequestBody(body);
        int statusCode = client.executeMethod(postMethod);
        System.out.println(postMethod.getResponseBodyAsString());

after running this code, I try getMethod using that restURL, the rest
server could return the cluster infomation, but only a litter infomation.
so ,  I doubt if the http body content is enough and if I missed some steps
before calling that restURL .   Please correct me , thanks.







2013/1/7 Yusaku Sako <yusaku@hortonworks.com>

> Hi Peicheng,
>
> The documentation that you referred is outdated and you will not be
> able to install a cluster if you simply follow it.  Sorry about
> that...
> AMBARI-666 was a development branch for the new, unreleased 1.2.0
> version of Ambari.  The code from this branch was merged to trunk
> about a month ago.
> We will be releasing 1.2.0 shortly (in a week or so) along with
> updated documentation.
> Please try again when 1.2.0 is released.
>
> Thanks for your patience!
>
> Yusaku
>
> On Sat, Jan 5, 2013 at 6:32 AM, peicheng Liao <peicheng5@gmail.com> wrote:
> > Hi all:
> >
> > I try to install Ambari-666 using the docs.
> >
> > Ambari-666 Development - Apache Ambari (Incubating) - Apache Software
> Foundation
> >
> https://cwiki.apache.org/confluence/display/AMBARI/Ambari-666+Development
> >
> > I start my ambari-server , and I  can it use
> >
> > http://am1:8080/api/check
> > staus return "RUNNING"
> >
> > Next I start ambari-web ,
> >
> > #cd ambari-web
> > # brunch w
> > but not thing happend
> > so I turn on the config.coffee
> >
> > server:
> >     port: 3333
> >     base: '/'
> >     run: no
> >
> > to
> >   server:
> >     port: 3333
> >     base: '/'
> >     run: yes
> >
> > 05 Jan 09:02:16 - info: application started on http://localhost:3333/
> >
> > =====
> > so I try to login the web ( user "admin" password "admin" ),
> > I found it sent request to http://am1:3333/api/v1/users/admin
> > (am1 is my server hostname,i can connect am1)
> > When I try to open the url  to check , It return
> > "Cannot GET /api/v1/users/admin "
> >
> > What kind mistake with me ?
> > Thank for your help ~
>

Mime
View raw message